Problème démarrage smb et nmb

Beta-Pictoris
Messages : 927
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème démarrage smb et nmb

Message par Beta-Pictoris » 15 février 2017, 21:42

antoine.vernier a écrit :J'ai créé un utilisateur 'technicien' avec les commandes :

Code : Tout sélectionner

adduser technicien
passwd technicien
smbpasswd -a technicien
Tu dois utiliser la commande pdbedit au lieu de smbpasswd pour ajouter un compte samba:

Code : Tout sélectionner

pdbedit -a -u technicien

antoine.vernier
Messages : 79
Inscription : 18 septembre 2016, 17:06

Re: Problème démarrage smb et nmb

Message par antoine.vernier » 15 février 2017, 22:20

Fait, mais toujours problème de droit d'accès

Beta-Pictoris
Messages : 927
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème démarrage smb et nmb

Message par Beta-Pictoris » 16 février 2017, 00:08

Essaye ceci:

Code : Tout sélectionner

chmod 777 /raid0/partage/backup{VM,PC}
Dernière modification par Beta-Pictoris le 17 février 2017, 16:25, modifié 3 fois.

antoine.vernier
Messages : 79
Inscription : 18 septembre 2016, 17:06

Re: Problème démarrage smb et nmb

Message par antoine.vernier » 16 février 2017, 01:04

Toujours rien.

Sinon, merci pour vos tentatives intrusion, j'ai bloquer le port SSH ^^
Merci CentOS qui informe des tentatives échoués de connexion en ssh à la session root.

Beta-Pictoris
Messages : 927
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème démarrage smb et nmb

Message par Beta-Pictoris » 16 février 2017, 17:22

antoine.vernier a écrit :Toujours rien.
Eventuellement désactiver le parefeu juste pour tester:

Code : Tout sélectionner

systemctl stop firewalld
antoine.vernier a écrit :Sinon, merci pour vos tentatives intrusion, j'ai bloquer le port SSH ^^
Tu as une machine avec un port ssh exposé sur internet ?

antoine.vernier
Messages : 79
Inscription : 18 septembre 2016, 17:06

Re: Problème démarrage smb et nmb

Message par antoine.vernier » 16 février 2017, 20:21

C'était le cas, jusqu'à que j'ai les messages en me connectant en ssh en local.

Beta-Pictoris
Messages : 927
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Problème démarrage smb et nmb

Message par Beta-Pictoris » 17 février 2017, 16:26

Si ça ne marche toujours pas, essaye ceci:

Code : Tout sélectionner

chown technicien.technicien /raid0/partage/backup{VM,PC}

antoine.vernier
Messages : 79
Inscription : 18 septembre 2016, 17:06

Re: Problème démarrage smb et nmb

Message par antoine.vernier » 21 février 2017, 01:36

Désoler du retard, j'ai refais à zéro la configuration du serveur.

Voilà la liste des commandes que j'ai exécuté :

Code : Tout sélectionner

yum install samba -y
chkconfig smb on
chkconfig nmb on
mkdir /raid0/partage/
mkdir /raid0/partage/backupVM
mkdir /raid0/partage/backupPC
chmod 777 /raid0/partage/backup{VM,PC}
cp /etc/samba/smb.conf /root/smb.conf.original
vi /etc/samba/smb.conf
service smb start
adduser technicien
passwd technicien
pdbedit -a -u technicien
service smb restart
testparm -s
firewall-cmd --permanent --zone=public --add-service=samba
firewall-cmd --reload
vi /etc/hosts
chown technicien.technicien /raid0/partage/backup{VM,PC}
Ma configuration est actuellement :

/etc/samba/smb.conf

Code : Tout sélectionner

# See smb.conf.example for a more detailed config file or
# read the smb.conf manpage.
# Run 'testparm' to verify the config is correct after
# you modified it.

[global]
        netbios name = NAS-Vernier
        workgroup = WORKGROUP
        server string = %h server (Samba, CentOS)
        security = user
        passdb backend = tdbsam
        load printers = no
        disable spoolss = Yes
        hosts allow = 127.0.0.1 192.168.1.0/24
        log file = /var/log/samba/log.%m
        max log size = 1000
        interfaces = eno1 lo
        bind interfaces only = yes

[backupVM]
        path = /raid0/partage/backupVM
        comment = Partage pour stocker saves VM
        public = yes
        writeable = yes
        browseable = yes
        valid users = technicien
        printable = no

[backupPC]
        path = /raid0/partage/backupPC
        comment = Partage pour stocker saves PC
        public = yes
        writeable = yes
        browseable = yes
        valid users = technicien
        printable = no
/etc/hosts

Code : Tout sélectionner

127.0.0.1       localhost
127.0.1.1       vernier.sytes.net NAS-Vernier
Sinon en désactivant le pare-feu, je peux me connecter sur le serveur en passant par l'explorateur réseau de Windows, je vois les 2 partages, mais impossible d'y accéder : "Windows ne peut pas accéder à \\NAS-Vernier\backupPC .... Vous ne disposez peut-être pas des autorisations ..."

antoine.vernier
Messages : 79
Inscription : 18 septembre 2016, 17:06

Re: Problème démarrage smb et nmb

Message par antoine.vernier » 21 février 2017, 19:01

Après plusieurs recherche, j'ai exécuté les commandes suivantes :

Code : Tout sélectionner

setsebool samba_domain_controller on
setsebool samba_enable_home_dirs on
firewall-cmd --permanent --add-service=samba
Sans avoir de changement.

Et je suis tombé sur ce poste : http://geekeries.de-labrusse.fr/?p=3150

J'ai exécuté les commandes :

Code : Tout sélectionner

setsebool -P samba_export_all_ro=1 samba_export_all_rw=1
getsebool –a | grep samba_export
et ça marche !
Dernière modification par antoine.vernier le 21 février 2017, 20:57, modifié 1 fois.

antoine.vernier
Messages : 79
Inscription : 18 septembre 2016, 17:06

Re: Problème démarrage smb et nmb

Message par antoine.vernier » 21 février 2017, 19:42

Je viens de rajouter la ligne

Code : Tout sélectionner

hide files = /desktop.ini/ntuser.ini/NTUSER.*/lost+found/
dans mon fichier : /etc/samba/smb.conf

Est-ce qu'il y a d'autres amélioration à faire ?

Répondre