Problème utilisation Wine

Blueberryone
Messages : 12
Inscription : 22 mars 2016, 18:49

Problème utilisation Wine

Message par Blueberryone » 24 mai 2017, 09:05

Bonjour à tous et à toutes,

J'ai installé en dur CentOS 7 (en minimal installation) pour pouvoir disposer de Mate Desktop que j'affectionne tout particulièrement.
Voici la procédure suivie pour cela dans un terminal administrateur:
1) yum install epel-release
2) yum groupinstall "X Window system"
3) yum groupinstall "MATE Desktop"
4) ln -sf /lib/systemd/system/graphical.target /etc/systemd/system/default.target
5) systemlctl isolate graphical.target

Jusque là tout se passe bien et le bureau Mate se lance sans problème.
Ensuite j'installe via Yum Extender l'application Wine présente dans les dépôts.
Tout se passe bien également et je peux donc le configurer.
C'est ici que commence les problèmes
Il m'est tout simplement impossible d'installer une application.exe
Lorsque je fais un clic droit sur l'application en question je demande qu'elle se lance avec le chargeur de programme wine mais rien ne se passe.
J'ai essayé de faire la même chose avec le bureau Gnome 3 mais le problème est pareil.
Je n'ai jamais eu ce genre de problème avec d'autres distributions.
Je ne comprend ce qui se passe!
Quelqu'un parmi vous peut-il m'aider à résoudre ce problème?
Je vous en remercie par avance.
CentOS 7 avec Mate Desktop 64bit

Avatar de l’utilisateur
nouvo09
Messages : 1822
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème utilisation Wine

Message par nouvo09 » 24 mai 2017, 12:03

En tout premier lieu, quel est l'état de SElinux ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Blueberryone
Messages : 12
Inscription : 22 mars 2016, 18:49

Re: Problème utilisation Wine

Message par Blueberryone » 24 mai 2017, 13:01

Bonjour nouvo09 et merci de te pencher sur mon problème.
Que veux-tu dire exactement par "quel est l'état de SElinux?"?
Comment fait-on pour connaître cet état?
CentOS 7 avec Mate Desktop 64bit

Avatar de l’utilisateur
nouvo09
Messages : 1822
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème utilisation Wine

Message par nouvo09 » 24 mai 2017, 16:42

Enfin tu as l'air suffisamment au courant des spécificités de Centos, je suis surpris que tu n'aies jamais entendu parler de SElinux.

alors une première approche:

https://fr.wikipedia.org/wiki/SELinux

et pour connaître l'état de Selinux dans ton système, tape dans un terminal la commande: getenforce
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Blueberryone
Messages : 12
Inscription : 22 mars 2016, 18:49

Re: Problème utilisation Wine

Message par Blueberryone » 24 mai 2017, 16:50

Salut nouvo09

Le résultat de getenforce est Disabled
CentOS 7 avec Mate Desktop 64bit

Blueberryone
Messages : 12
Inscription : 22 mars 2016, 18:49

Re: Problème utilisation Wine

Message par Blueberryone » 24 mai 2017, 16:57

De ce que je crois comprendre après avoir fait quelques recherches sur internet, il semble que le problème soit dû au fait que je suis sous CentOS 7 64bit alors que le logiciel windows que je dois utiliser est 32 bit.
J'ai donc compilé les versions 64 et 32 bit de Wine.
Cela fonctionne partiellement!
En effet l'affichage des textes est vraiment horrible (c'est pas du TrueType!).
Y a-t-il un moyen de régler ça?
Merci d'avance
CentOS 7 avec Mate Desktop 64bit

Répondre