[Résolu] Activation permanente des haut-parleurs

Hive
Messages : 20
Inscription : 07 septembre 2015, 14:07

[Résolu] Activation permanente des haut-parleurs

Message par Hive » 16 septembre 2015, 14:08

Bonjour tout le monde.

J'ai un soucis mineur mais fort ennuyant avec le son de mon PC sous Centos 7. En gros les haut-parleurs sont fonctionnels mais ne s'activent pas automatiquement. Ils sont pourtant très bien détectés dans les paramètres de son, mais les seules fois où j'arrive à les faire fonctionner, c'est lorsque je branche puis débranche des écouteurs. Et encore, il suffit que je ferme un onglet youtube pour que le son se re-bloque. Je doit à chaque fois faire la manip brancher/débrancher des écouteurs et c'est vite usant.

Je précise que je n'ai rien installé en rapport avec le son sur ce PC, tout est d'origine. De plus ça semble être global car je n'entends plus non plus les effets sonores internes.

En vous remerciant de votre aide.
Dernière modification par Hive le 01 février 2016, 11:49, modifié 1 fois.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Activation permanente des haut-parleurs

Message par Beta-Pictoris » 16 septembre 2015, 16:56


Hive
Messages : 20
Inscription : 07 septembre 2015, 14:07

Re: Activation permanente des haut-parleurs

Message par Hive » 17 septembre 2015, 16:26

Merci, mais ça n'a pas réglé mon problème.

Code : Tout sélectionner

alsactl store

n'a rien donnée, tout comme la suppression de la ligne

Code : Tout sélectionner

load-module module-switch-on-port-available
dans /etc/pulse/default.pa.

Le son finit toujours par se couper à un moment ou à un autre :(

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Activation permanente des haut-parleurs

Message par Beta-Pictoris » 17 septembre 2015, 20:30

Je suppose que tu n'as pas vu de "Auto-Mute" mode dans alsamixer, comme ici ? : http://superuser.com/questions/431079/h ... -mute-mode
(Tu peux faire défiler les barres de contrôle qui n'apparaissent pas dans alsamixer en utilisant la touche directionnelle droite.)

Ton ordinateur a plusieurs sorties audio (casque, analogique, hdmi,... ) ? Si c'est le cas, as tu vérifié sur quelle sortie il était configuré par défaut ?

Quelle est la référence de la puce audio ?

Hive
Messages : 20
Inscription : 07 septembre 2015, 14:07

Re: Activation permanente des haut-parleurs

Message par Hive » 18 septembre 2015, 14:04

Autant pour moi, on dirait que ça fonctionne. Je n'avais pas pris la peine (pourtant élémentaire) de redémarrer mon ordinateur hier après avoir fait:

Code : Tout sélectionner

alsactl store
Pour l'instant le son vient tout seul et ne s'est pas encore coupé. Merci pour l'aide !

Hive
Messages : 20
Inscription : 07 septembre 2015, 14:07

Re: Activation permanente des haut-parleurs

Message par Hive » 18 septembre 2015, 16:44

Bon en fait ça continue de planter lorsqu'il n'y a plus de son pendant un moment (genre une pause de 10 secondes), puisqu'il se mute automatiquement.

Avec alsamixer, je n'ai qu'un paramètre "master" (les enceintes par défaut, je suppose) où je peut régler le volume.

Ce n'est que lorsque que je chage de carte son que je vois un écran similaire à celui du lien. Je vois bien une option "Auto-Mute Mode" mais elle est réglée sur "Disabled".

Pour les sorties audio, il n'y a rien à part les enceintes intégrées à la tour du PC. Dans les paramètres son, c'est bien réglé par défaut sur Haut-parleurs - Audio externe.

Quant à la puce audio : Realtek ALC262

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Activation permanente des haut-parleurs

Message par Beta-Pictoris » 18 septembre 2015, 17:10

Le module audio ne reconnaît pas correctement ton matériel. Tu peux lui forcer la main en créant un fichier /etc/modprobe.d/audio.conf et en lui ajoutant ceci:

Code : Tout sélectionner

options snd-hda-intel model=<model>
<model> est un des modèles de carte audio listé ici: https://www.kernel.org/doc/Documentatio ... Models.txt

L'idée est de tester différents modèles de cartes audios. Voir un exemple ici: http://ubuntuforums.org/showthread.php?t=1542375

Il faut redémarrer ta machine pour que les changements soient pris en charge.

Hive
Messages : 20
Inscription : 07 septembre 2015, 14:07

Re: Activation permanente des haut-parleurs

Message par Hive » 22 septembre 2015, 09:07

Merci pour l'aide. Je regarde ça et je tiens au courant de l'avancée.

Hive
Messages : 20
Inscription : 07 septembre 2015, 14:07

Re: Activation permanente des haut-parleurs

Message par Hive » 01 octobre 2015, 09:27

Bon je viens de faire quelques tests avec le fichier audio.conf et après plusieurs redémarrages, le problème persiste. Je vais laisser tomber pour l'instant, j'ai trouvé un petit trick qui rend la chose moins supportable : il suffit que je mette le son au minimum puis que je le remonte pour désactiver le mute. C'est pas la panacée mais pour l'instant je m'en contente, ça n'est qu'un petit coup de molette.

Merci pour l'aide Beta-Pictoris.

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Activation permanente des haut-parleurs

Message par Beta-Pictoris » 02 octobre 2015, 14:12

Tu peux, aussi, tester avec un noyau linux plus récent. Tu en trouveras un dans les dépots elrepo.

Répondre