Page 3 sur 3

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 30 octobre 2016, 19:03
par buisson
Bon, j'arrive à me remettre sur mon pb ...

Je viens de désactiver SELinux et modifier le xorg.conf en mettant les 2 cartes comme précisé sur le post transmis mais rien n'y fait.

Du coup, étant donné que cela fait une semaine que je tourne en rond sur ce pb, j'ai craqué et réinstallé la totale sans effacer le /home naturellement. Je me retrouve maintenant avec une config qui fonctionne mais peut-être pas avec nvidia ...

je ne maîtrise pas assez linux pour pouvoir installer et gérer les pb inhérents à une config matérielle optimus. Cela fait peu de temps que je suis sous CentOs et je suis plus habitué à Debian ...

Petite remarque : les forums et documentations pour Debian et dérivés (Ubuntu par exemple) sont tout de même plus complets que sous RedHat.

Sinon, je vous remercie pour vos aides respectives car vous m'avez motivé à plonger dans les logs. Chapeau les gars !!!

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 30 octobre 2016, 22:13
par nouvo09
Tu peux toujours faire une sauvegarde complète de ton système actuel puis jouer à installer le pilote Nvidia à nouveau ?

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 31 octobre 2016, 09:02
par buisson
Salut nouvo09,

J'y ai pensé (clonage pour pouvoir retrouver une config propre ...). Pour l'instant, je n'ai pas trop le temps mais les périodes de vacances sont propices à ce genre d'investigation ...

Bonne journée.

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 31 octobre 2016, 11:38
par Beta-Pictoris
buisson a écrit : Je viens de désactiver SELinux et modifier le xorg.conf en mettant les 2 cartes comme précisé sur le post transmis mais rien n'y fait.
As tu appliqué le fichier xorg.cong proposé sur le wiki archlinux ? : https://wiki.archlinux.org/index.php/NVIDIA_Optimus

Code : Tout sélectionner

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    # Change BusID if necessary. Tips: (lspci | grep 3D) (Change 01:00.0 to 1:0:0)
    BusID "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "Yes"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    # Change BusID if necessary. Tips: (lspci | grep VGA) (Change 00:02.0 to 0:2:0)
    BusID "PCI:0:2:0"
    Option "AccelMethod"  "none"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection
Sur ce wiki, tu as aussi une configuration avec une seule carte vidéo. Tu l'as essayé ? :

Code : Tout sélectionner

Section "Module"
    Load "modesetting"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "<BusID for NVIDIA device here>"
    Option "AllowEmptyInitialConfiguration"
EndSection

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 31 octobre 2016, 11:45
par Beta-Pictoris
buisson a écrit :Petite remarque : les forums et documentations pour Debian et dérivés (Ubuntu par exemple) sont tout de même plus complets que sous RedHat.
En ce qui concerne la prise en charge des cartes vidéos amd/nvidia, ce n'est pas l'objectif et, donc, le point fort des distributions redhat/centos. Si on reste dans la même famille, la Fedora sera plus appropriée pour ce genre de chose.
Par contre, en ce qui concerne l'administration des serveurs, la documentation redhat est très complète et très pointue:
https://access.redhat.com/documentation ... ise-linux/
On ne trouve pas, à ma connaissance, l'équivalent d'une telle documentation chez Debian par exemple.

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 31 octobre 2016, 13:49
par nouvo09
J'ignore pour Nvidia car je n'en ai jamais eu. Mais pour ce qui concerne les pilotes AMD/ATI pour RHEL/CentOs, ils ont toujours fonctionné "out of the box" tant sur Centos 5 que 6 ou 7.

On en est loin sur Fedora. En revanche la question des machines multicartes/multiécrans est probablement mieux discutée sur le forum Fedora plus branchée desktop.

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 03 novembre 2016, 16:35
par buisson
Pour répondre à Béta-Pictoris,

J'avais effectivement essayé les fichiers xorg.conf qu'il a cité ... Mais en vain ...

Re: lenovo W541 : pb carte nvidia impossible à monter

Publié : 03 novembre 2016, 18:53
par Beta-Pictoris
A noter, sur le wiki Fedora, il est stipulé qu'un noyau linux 3.17 est nécessaire pour faire fonctionner Optimus: http://doc.fedora-fr.org/wiki/Support_d'Optimus

Le noyau de la Centos 7 n'est qu'en 3.10...