[Home-Lab] Routage

Alexandre
Messages : 2
Inscription : 23 mars 2016, 21:45

[Home-Lab] Routage

Message par Alexandre » 23 mars 2016, 22:05

Bonsoir a tous , amis Centosiens , je viens poser ma question en esperant qu'il y ait une réponse ? je souhaite faire du routage en home lab pour faire des test avec une machine physique avant de mettre tout ça en prod sur des PC mini ITX .

actuellement j'ai ma livebox qui me sert de modem routeur pour aceder a internet elle a pour ip : 192.168.1.1 .

par soucis de place , je suis obligé de mettre un repeteur wifi pour recuperer le wifi de la livebox ce repeteur a une ip : 192.168.1.100 , il ne fait pas dns et c'est un produit grand publique sans trop doptions appart un bouton start stop le DHCP du repeteur et fixer l'adresse ip du peripherique .

ce que je souhaite c'est utiliser CentOS avec deux carte réseau le princpe est simple, mais étant débutant dans le domaine, je ne comprends pas comment y parvenir :

ce que je souhaite faire c'est récuperer ce qui sort du répeteur en ethernet, pour ça le répéteur le fait , pas de problèmes, je récupere le signal internet a travers mon cable ethernet qui lui est relié sur la première interface réseau de CentOS7 :

- enp2s0, ip : 192.168.1.130

a présent je souhaite rediriger tout ce qui rentre dans enp2s0 vers enp3s7 : 192.168.2.1 .

jusque la j'y suis arrivé, j'ai monté un DHCP sur el serveur, et ditribue sur une plage de 192.168.2.0/24 a partir de l'ip 192.168.2.2

le DHCP fonctionne tout est ok .

pour que le nat arrive a ce sous réseau , j'ai supprimé firewalld ( yum remove firewalld ) et j'ai installé le paquet iptables-services .

j'ai constaté qu'il fallais utiliser la regle de post routing MASQUERADE, en gros on fait croire au réseau 192.168.2.0/24 qu'il est en réalité 192.168.1.0/24 . et ça marche j'ai internet . je n'ai pas touché a la table de routage, mais j'ai suivi un tutoriel sur internet ( 8 videos ) https://www.youtube.com/watch?v=zG51Pc8OP4M

mais je n'arrive pas a faire comuniquer le réseau dans les deux sens, a lheure actuelle il m'est uniquement possible de pinguer 192.168.1.0/24 depuis un ordinateur sur 192.168.2.0/24 , l'inverse ne fonctoinne pas ... je pense que cela vient du fait que ma livebox n'a pas de table de routage pour renvoyer les paquets, mais aussi du fait que j'utilise MASQUERADE . quand je fait un tracert depuis windows, j'obtierns des sauts d'ip de mon pc vers la livebox mais me donne une IP a la noix en guise de réponse .


ma question est simplement comment je pourrais faire pour faire en sorte que les deux réseaux puissent comuniquer en utlilisant CentOS ?

Beta-Pictoris
Messages : 898
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: [Home-Lab] Routage

Message par Beta-Pictoris » 23 mars 2016, 23:45

Si j'ai bien compris, ton ordinateur centos fait office de routeur entre tes 2 réseaux.
Si c'est le cas, tu ne peux pas pinger un ordinateur qui se trouve derrière un routeur nat.
Tu dois, donc, retirer le nat, activer le routage dans ta centos et ajouter une règle de routage dans ta box pour que cettte dernère reconnaisse ton réseau en 192.168.2.0/24.

Alexandre
Messages : 2
Inscription : 23 mars 2016, 21:45

Re: [Home-Lab] Routage

Message par Alexandre » 24 mars 2016, 11:48

hello, oui c'est bien ça .

pour comment faire pour enlever le nat ? je supprime la règle dans iptables ? c'est bien ça ?

mais ensuite, comment activer le routage ?

je ne peux pas accéder aux tables de routage de ma LiveBox ( orange ) car elles sont verrouillées depuis longtemps plus d'acces possible .

il n'y a pas un autre moyen de faire communiquer ces deux réseaux ?

si jamais cela n’était pas possible autrement, il serais possible de mettre un rasberri PI qui me servirait de "table de routage" ? du coup ce dernier serait positionné entre la livebox et le répéteur et en toute logique enverrai la réponse aux pings avec la bonne redirection des paquets ?

Beta-Pictoris
Messages : 898
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: [Home-Lab] Routage

Message par Beta-Pictoris » 24 mars 2016, 19:47

Alexandre a écrit :comment faire pour enlever le nat ? je supprime la règle dans iptables ? c'est bien ça ?
Oui.
Alexandre a écrit :mais ensuite, comment activer le routage ?
Tu fais ceci:

Code : Tout sélectionner

sysctl net.ipv4.ip_forward=1
sysctl -w net.ipv4.ip_forward=1
Alexandre a écrit :je ne peux pas accéder aux tables de routage de ma LiveBox ( orange ) car elles sont verrouillées depuis longtemps plus d'acces possible .
Essaye de faire un reset hard de ta box.
Alexandre a écrit :il n'y a pas un autre moyen de faire communiquer ces deux réseaux ?
On peut faire du "forwarding de port" (pat) avec iptables.
Alexandre a écrit :si jamais cela n’était pas possible autrement, il serais possible de mettre un rasberri PI qui me servirait de "table de routage" ?
Non.

Répondre