problème SSH

Répondre
Bibaros
Messages : 16
Inscription : 29 janvier 2016, 15:51

problème SSH

Message par Bibaros » 18 septembre 2016, 20:56

Bonjour ,
j'essaye de se connecter à un ordinateur qui a centos 7 comme système d'exploitation via ssh en utilisant putty sur un windows 8 comme client , en local ça marche mais si j'utilise l'adresse IP fournit par mon FSI j'ai le message d'erreur : Network error : connection refused .
NB j'ai ouvert un port sur mon modem .
Merci par avance ,

Beta-Pictoris
Messages : 898
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème SSH

Message par Beta-Pictoris » 18 septembre 2016, 22:27

Tu as activé un forwading de port. Est ce que tu testes bien d'un pc ne se trouvant pas en local (derrière ta box internet) ?
Peux-tu faire un scan des ports de ta machine centos avec un programme comme nmap ?

Bibaros
Messages : 16
Inscription : 29 janvier 2016, 15:51

Re: problème SSH

Message par Bibaros » 19 septembre 2016, 12:11

Beta-Pictoris a écrit :Tu as activé un forwading de port. Est ce que tu testes bien d'un pc ne se trouvant pas en local (derrière ta box internet) ?
Peux-tu faire un scan des ports de ta machine centos avec un programme comme nmap ?
Merci pour votre réponse, oui j'ai bien activé un forwarding et j'ai indiqué le port 22 et l'adresse IP de mon serveur centos , nmap -sT -p 22 adresse_machine indique bien que le port ouvert .... c'est bizarre !!!

Beta-Pictoris
Messages : 898
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème SSH

Message par Beta-Pictoris » 19 septembre 2016, 13:05

Tu devrais essayer avec un client ssh sous linux.

Bibaros
Messages : 16
Inscription : 29 janvier 2016, 15:51

Re: problème SSH

Message par Bibaros » 19 septembre 2016, 21:44

Beta-Pictoris a écrit :Tu devrais essayer avec un client ssh sous linux.
voilà l résultat depuis un ubuntu

Code : Tout sélectionner

ssh connect to host port 22 :connection refused
sachant que ca marche aussi en local avec ubuntu

Beta-Pictoris
Messages : 898
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème SSH

Message par Beta-Pictoris » 19 septembre 2016, 22:11

Essaye de te connecter en mode verbose:

Code : Tout sélectionner

ssh -v
ssh -vv
ssh -vvv
Regarde les logs coté serveur.

Que donne ?

Code : Tout sélectionner

netstat -ltpn

Bibaros
Messages : 16
Inscription : 29 janvier 2016, 15:51

Re: problème SSH

Message par Bibaros » 19 septembre 2016, 22:44

Beta-Pictoris a écrit :Essaye de te connecter en mode verbose:

Code : Tout sélectionner

ssh -v
ssh -vv
ssh -vvv
Regarde les logs coté serveur.

Que donne ?

Code : Tout sélectionner

netstat -ltpn
ssh -v sami@xxxxxxxxxx
OpenSSH_7.2p2 Ubuntu-4ubuntu2.1, OpenSSL 1.0.2g-fips 1 Mar 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to xxxxxxxxx [xxxxxxxx] port 22.
debug1: connect to address xxxxxxxxx port 22: Connection refused
ssh: connect to host xxxxxxxxx port 22: Connection refused

Code : Tout sélectionner

netstat -ltpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name    
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      889/rpcbind         
tcp        0      0 192.168.1.5:22          0.0.0.0:*               LISTEN      3901/sshd           
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      3252/cupsd          
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      2666/master         
tcp6       0      0 :::111                  :::*                    LISTEN      889/rpcbind         
tcp6       0      0 ::1:631                 :::*                    LISTEN      3252/cupsd          
tcp6       0      0 ::1:25                  :::*                    LISTEN      2666/master         

Beta-Pictoris
Messages : 898
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème SSH

Message par Beta-Pictoris » 20 septembre 2016, 09:00

Par défaut, le daemon sshd écoute sur toutes les interfaces réseaux.
Ici, il écoute, uniquement, sur l'interface 192.168.1.5.
Tu as modifié ton fichier /etc/ssh/sshd_config ?

Que donne ? :

Code : Tout sélectionner

sudo journalctl _COMM=sshd

Bibaros
Messages : 16
Inscription : 29 janvier 2016, 15:51

Re: problème SSH

Message par Bibaros » 21 septembre 2016, 15:24

Beta-Pictoris a écrit :Par défaut, le daemon sshd écoute sur toutes les interfaces réseaux.
Ici, il écoute, uniquement, sur l'interface 192.168.1.5.
Tu as modifié ton fichier /etc/ssh/sshd_config ?

Que donne ? :

Code : Tout sélectionner

sudo journalctl _COMM=sshd
bonjour
oui j'ai modifié le fichier sshd_config et 192.168.1.5 c'est l'adresse local du serveur
sudo journalctl _COMM=sshd donne

Code : Tout sélectionner

-- Logs begin at Wed 2016-09-21 09:13:15 EDT, end at Wed 2016-09-21 09:17:47 EDT. -- 

Beta-Pictoris
Messages : 898
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: problème SSH

Message par Beta-Pictoris » 21 septembre 2016, 18:54

Bibaros a écrit :oui j'ai modifié le fichier sshd_config et 192.168.1.5 c'est l'adresse local du serveur
Est-ce que tu as modifié autre chose dans ce fichier ?
Bibaros a écrit :sudo journalctl _COMM=sshd donne

Code : Tout sélectionner

-- Logs begin at Wed 2016-09-21 09:13:15 EDT, end at Wed 2016-09-21 09:17:47 EDT. -- 
Tu dois tester coté serveur pour avoir quelque chose comme ceci:

Code : Tout sélectionner

-- Logs begin at mer. 2016-09-21 18:09:37 CEST, end at mer. 2016-09-21 18:25:21 CEST. --
sept. 21 18:09:49 alpha.local.home sshd[1014]: Server listening on 0.0.0.0 port 22.
sept. 21 18:09:49 alpha.local.home sshd[1014]: Server listening on :: port 22.
As tu modifié la configuration de parefeu ?
Vérifie les logs du fichier /var/log/firewalld.
Teste en désactivant le parefeu (firewalld/iptables) et selinux.

Si ça ne marche, toujours, pas après ça, revérifie la configuration parefeu de ton routeur.

Répondre