configurer cle USB/Ethernet [Résolu]

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 17 septembre 2018, 20:25

Je ne sais pas quel type de test tu fais pour vérifier s'il y a une connexion réseau. Si, par exemple, tu essayes de pinger ta machine linux, ça pourra ne pas fonctionner à cause du pare-feu (firewalld).
C'est pourquoi tu dois, d'abord, tester ton adaptateur ethernet usb en reliant à ta box internet. Parce que ta box internet va lui fournir une adresse ip en dhcp. Mais tu as fixé une adresse ip sur ton interface réseau. Tu dois, donc, repasser l'option ipv4.method en mode auto et redémarrer ton interface réseau.
Que donne ?

Code : Tout sélectionner

nmcli connection show enp0s20u2
Au boot, sur le menu grub, tu choisis bien le nouveau noyau ?

trazomtg
Messages : 131
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 18 septembre 2018, 12:31

j'ai connecté a machine "serveur" à ma box via la cle USB/Ethernet et ça a fonctionné. Sans wifi bien sûr.
Le problème vient donc de ma machine connectée à mon "serveur" via le switch.

merci pour ton idée.

j'ai essayé d'utiliser la commande "nmtui" pour paramètrer ma connexion mais ça ne fonctionne pas; la commande produit des effets bizarres.
ça ne marche pas mieux avec NetworkManager
je vais donc essayer d'utiliser la commande "nmcli"; avec ton aide évidemment :roll:

la commande ip r me renvoie :

Code : Tout sélectionner

[root@dell-centos ~]# ip r
default via 192.168.0.1 dev p5p1 proto static metric 100 
192.168.0.0/24 dev p5p1 proto kernel scope link src 192.168.0.5 metric 100 
192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1 linkdown 
192.168.0.1 est l'adresse de mon interface USB/Ethernet coté Lan de mon "serveur"
je ne comprends pas les 2 autres lignes

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 18 septembre 2018, 16:12

Essaye de mettre l'interface réseau de ta machine dans la zone trusted du pare-feu:

Code : Tout sélectionner

firewall-cmd --zone=trusted --change-interface=p5p1

trazomtg
Messages : 131
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 18 septembre 2018, 19:36

"p5p1" est l'interface ethernet de ma machine cliente, connectée à ma machine "serveur" Tu es sûr que c'est sur cette machine qu'il faut passer cette commande?
pas sur l'interface lan "enp0s20u2" de mon serveur?

je l'ai passée sur ma machine cliente mais ça n'a rien changé

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 18 septembre 2018, 19:51

Oui, cela permet d'ouvrir le pare-feu.
Fais le aussi sur ta machine serveur:

Code : Tout sélectionner

firewall-cmd --zone=trusted --change-interface=enp0s20u2
Essaye, ensuite, de faire des pings.

trazomtg
Messages : 131
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 18 septembre 2018, 20:35

depuis ma machine "serveur" je me suis connecté en SSH sur ma machine "client" et j'ai fait des ping:

Code : Tout sélectionner

[root@Centos7-msi ~]# ssh 192.168.0.5
The authenticity of host '192.168.0.5 (192.168.0.5)' can't be established.
ECDSA key fingerprint is SHA256:50KnftjhK2CMQmz0g8iDkmjg/PcDob3IXV1TY8iBu1o.
ECDSA key fingerprint is MD5:c7:f6:fa:54:31:9c:57:95:f8:8d:0f:c0:92:c9:6a:3e.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.5' (ECDSA) to the list of known hosts.
root@192.168.0.5's password: 
Last login: Tue Sep 18 20:12:34 2018

Code : Tout sélectionner

[root@dell-centos ~]# ping 1923.168.0.1
ping: 1923.168.0.1: Nom ou service inconnu
[root@dell-centos ~]# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.
64 bytes from 192.168.0.1: icmp_seq=1 ttl=64 time=0.363 ms
64 bytes from 192.168.0.1: icmp_seq=2 ttl=64 time=0.392 ms
^C
--- 192.168.0.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1031ms
rtt min/avg/max/mdev = 0.363/0.377/0.392/0.024 ms
[root@dell-centos ~]# ping 192.168.1.20
PING 192.168.1.20 (192.168.1.20) 56(84) bytes of data.
64 bytes from 192.168.1.20: icmp_seq=1 ttl=64 time=0.346 ms
64 bytes from 192.168.1.20: icmp_seq=2 ttl=64 time=0.456 ms
^C
--- 192.168.1.20 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1055ms
rtt min/avg/max/mdev = 0.346/0.401/0.456/0.055 ms
et depuis le "serveur" :

Code : Tout sélectionner

[root@Centos7-msi ~]# ping 192.168.0.5
PING 192.168.0.5 (192.168.0.5) 56(84) bytes of data.
64 bytes from 192.168.0.5: icmp_seq=1 ttl=64 time=0.445 ms
64 bytes from 192.168.0.5: icmp_seq=2 ttl=64 time=0.477 ms
tout fonctionne n'est ce pas?
mais je ne peux pas me connecter à internet depuis ma machine cliente

j'ai trouvé 2 docs intéressantes:
https://access.redhat.com/documentation ... ing_guide/
https://www.certdepot.net/?s=firewal&submit=Go

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 18 septembre 2018, 21:26

Essaye le mode 'shared' sur ta machine serveur:

Code : Tout sélectionner

nmcli connection modify enp0s20u2 ipv4.method shared
nmcli connection down enp0s20u2
nmcli connection up enp0s20u2
Passe ta machine client en mode "auto":

Code : Tout sélectionner

nmcli connection modify p5p1 ipv4.method auto
nmcli connection down p5p1
nmcli connection up p5p1

trazomtg
Messages : 131
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 19 septembre 2018, 13:30

salut!

je viens de passer la commande:

Code : Tout sélectionner

[root@Centos7-msi ~]# nmcli connection modify "enp0s20u2" ipv4.method shared
Erreur : connexion inconnue : « enp0s20u2 ».
[root@Centos7-msi ~]# nmcli connection modify enp0s20u2 ipv4.method shared
Erreur : connexion inconnue : « enp0s20u2 ».
bizarre!!

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 19 septembre 2018, 14:28

Oui, c'est normal, il faut appeler un profil par son uuid ou par son nom, mais pas par son interface réseau. Généralement, on renomme le nom du profil avec le nom de l'interface.
Regarde le nom des profils ou leurs uuid et utilise le bon.

trazomtg
Messages : 131
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 19 septembre 2018, 16:27

voici ce que j'ai quand je branche mon cable ethernet:

Code : Tout sélectionner

[root@dell-centos ~]# journalctl -xe
sept. 19 16:20:30 dell-centos dbus[970]: [system] Successfully activated service 'org.kde.powerdevil.backlighthelper'
sept. 19 16:21:41 dell-centos kernel: r8169 0000:01:00.0 p5p1: link down
sept. 19 16:21:47 dell-centos NetworkManager[1040]: <info>  [1537366907.5547] device (p5p1): state change: activated -> unavailable (reason 'carrier-changed', sys-iface-state: 'managed')
sept. 19 16:21:47 dell-centos dbus[970]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
sept. 19 16:21:47 dell-centos systemd[1]: Starting Network Manager Script Dispatcher Service...
-- Subject: L'unité (unit) NetworkManager-dispatcher.service a commencé à démarrer
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- L'unité (unit) NetworkManager-dispatcher.service a commencé à démarrer.
sept. 19 16:21:47 dell-centos dbus[970]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
sept. 19 16:21:47 dell-centos systemd[1]: Started Network Manager Script Dispatcher Service.
-- Subject: L'unité (unit) NetworkManager-dispatcher.service a terminé son démarrage
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- L'unité (unit) NetworkManager-dispatcher.service a terminé son démarrage, avec le résultat done.
sept. 19 16:21:47 dell-centos nm-dispatcher[25277]: req:1 'down' [p5p1]: new request (4 scripts)
sept. 19 16:21:47 dell-centos nm-dispatcher[25277]: req:1 'down' [p5p1]: start running ordered scripts...
sept. 19 16:23:27 dell-centos kernel: r8169 0000:01:00.0 p5p1: link up
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2047] device (p5p1): carrier: link connected
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2076] device (p5p1): state change: unavailable -> disconnected (reason 'carrier-changed', sys-iface-state: 'managed')
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2095] policy: auto-activating connection 'connexion_fil'
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2111] device (p5p1): Activation: starting connection 'connexion_fil' (1e8b549b-d4a0-3d16-8840-43045a401a55)
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2114] device (p5p1): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2116] manager: NetworkManager state is now CONNECTING
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2120] device (p5p1): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2323] device (p5p1): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2374] device (p5p1): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2388] device (p5p1): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2391] device (p5p1): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.2393] manager: NetworkManager state is now CONNECTED_LOCAL
sept. 19 16:23:27 dell-centos NetworkManager[1040]: <info>  [1537367007.6299] device (p5p1): Activation: successful, device activated.
sept. 19 16:23:27 dell-centos dbus[970]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
sept. 19 16:23:27 dell-centos systemd[1]: Starting Network Manager Script Dispatcher Service...
-- Subject: L'unité (unit) NetworkManager-dispatcher.service a commencé à démarrer
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- L'unité (unit) NetworkManager-dispatcher.service a commencé à démarrer.
sept. 19 16:23:27 dell-centos dbus[970]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
sept. 19 16:23:27 dell-centos systemd[1]: Started Network Manager Script Dispatcher Service.
-- Subject: L'unité (unit) NetworkManager-dispatcher.service a terminé son démarrage
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- L'unité (unit) NetworkManager-dispatcher.service a terminé son démarrage, avec le résultat done.
sept. 19 16:23:27 dell-centos nm-dispatcher[25396]: req:1 'up' [p5p1]: new request (4 scripts)
sept. 19 16:23:27 dell-centos nm-dispatcher[25396]: req:1 'up' [p5p1]: start running ordered scripts...
sept. 19 16:23:27 dell-centos systemd[1]: Unit iscsi.service cannot be reloaded because it is inactive.
et voici ce que j'obtiens quand je debranche le cable :

Code : Tout sélectionner

[root@dell-centos ~]# journalctl -xe
sept. 19 16:26:42 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:42 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:46 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:46 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:46 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:46 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:47 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:47 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:47 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:47 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:50 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:51 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:51 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:51 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:51 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5: AER: Multiple Corrected error received: 0000:00:1c.5
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:52 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5: AER: Corrected error received: 0000:00:1c.5
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Data Link Layer, (Transmitter ID)
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5:   device [8086:9d15] error status/mask=00001000/00002000
sept. 19 16:26:54 dell-centos kernel: pcieport 0000:00:1c.5:    [12] Replay Timer Timeout  
je vais chercher ce que c'est

Répondre