configurer cle USB/Ethernet [Résolu]

trazomtg
Messages : 127
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 22 septembre 2018, 14:16

j'ai passé tes commandes sur le serveur coté Lan

Code : Tout sélectionner

[root@Centos7-msi network-scripts]# nmcli con show
NAME                 UUID                                  TYPE      DEVICE    
Connexion filaire 1  58aa846d-bfa8-3134-a403-c73eea40fc4d  ethernet  enp0s20u2 
connexion filaire    f567956d-9d5a-4a2a-9090-8d853f679d74  ethernet  enp4s0    
Freebox-4B26F0       0664be9a-f11a-4bbc-a553-560921e3dbd8  wifi      --        
[root@Centos7-msi network-scripts]# nmcli connection edit 58aa846d-bfa8-3134-a403-c73eea40fc4d

===| éditeur de connexions interactives nmcli |===

Modification de la connexion « 802-3-ethernet » : « 58aa846d-bfa8-3134-a403-c73eea40fc4d »

Saisissez « help » ou « ? » pour les commandes disponibles.
Saisissez « describe [<setting>.<prop>] »  pour une description de propriété détaillée.

Vous pouvez modifier les paramètres suivants : connection, 802-3-ethernet (ethernet), 802-1x, dcb, ipv4, ipv6, tc, proxy
nmcli> set ipv4.method shared
Souhaitez-vous aussi supprimer « ipv4.addresses » ? [yes] : yes
nmcli> verify
Vérifier la connexion : ipv4.gateway: la passerelle ne peut pas être définie si aucune adresse est configurée
nmcli> save
Erreur : échec de la vérification de la connexion : ipv4.gateway: la passerelle ne peut pas être définie si aucune adresse est configurée
Vous devriez exécuter « verify fix » pour régler les erreurs.erify
nmcli> activate
Erreur : la connexion n'est pas enregistrée. Commencez par saisir « save ».
nmcli> save
Erreur : échec de la vérification de la connexion : ipv4.gateway: la passerelle ne peut pas être définie si aucune adresse est configurée
Vous devriez exécuter « verify fix » pour régler les erreurs.erify
nmcli> verify fix
Vérifier la connexion : ipv4.gateway: la passerelle ne peut pas être définie si aucune adresse est configurée
L'erreur ne peut pas être résolue automatiquement
comme tu le vois ça ne fonctionne pas!

est ce que je peux "supprimer" la connexion su serveur cote Lan et la recréer simplement en re-connectant la cle USB/ethernet?

pareil sur la machine cliente
merci

Beta-Pictoris
Messages : 976
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 22 septembre 2018, 16:02

Vérifie s'il y a une passerelle de configurée:

Code : Tout sélectionner

nmcli connection show 58aa846d-bfa8-3134-a403-c73eea40fc4d
Si c'est le cas, il faudra la supprimer:

Code : Tout sélectionner

nmcli connection edit 58aa846d-bfa8-3134-a403-c73eea40fc4d
remove ipv4.gateway
set ipv4.method shared
verify
save
activate
CTRL−D

trazomtg
Messages : 127
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 22 septembre 2018, 20:45

je sais pas quoi répondre à cette question

Code : Tout sélectionner

nmcli> set ipv4.method shared
Souhaitez-vous aussi supprimer « ipv4.addresses » ? [yes] :
je ne pense pas puisque ça correspond à l'adresse ip de mon interface Lan à savoir 192.168.0.1 mais bon!!!
j'ai répondu "no" et j'ai reçu une erreur:

Code : Tout sélectionner

nmcli> remove ipv4.gateway
nmcli> verify
Vérifier la connexion : OK
nmcli> set ipv4.method shared
Souhaitez-vous aussi supprimer « ipv4.addresses » ? [yes] : no
nmcli> verify
Vérifier la connexion : OK
nmcli> save
Connexion « Connexion filaire 1 » (58aa846d-bfa8-3134-a403-c73eea40fc4d) mise à jour.
nmcli> activate
Contrôle de l'activation de la connexion (appuyez sur n'importe quelle touche pour continuer)
Erreur : échec de l'activation de la connexion.
Dernière modification par trazomtg le 22 septembre 2018, 20:50, modifié 1 fois.

Beta-Pictoris
Messages : 976
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 22 septembre 2018, 20:50

Si, vas-y ! supprime.

trazomtg
Messages : 127
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 23 septembre 2018, 08:14

bonjour,
ça ne fonctionne pas :?

quand je regarde les connexions via l'interface graphique de NetworkManager j'obtiens:

sur mon serveur:
coté Lan: zone de pare-feu trusted réglages de base et méthode= DHCP
coté Wan: la même chose

sur mon client : zone de pare-feu= trusted réglages de base et Méthode = manuelle; adresse ip = 192.168.0.5 passerelle = 192.168.0.1

la commande ip a me retourne : (sur le serveur)

Code : Tout sélectionner

[root@Centos7-msi network-scripts]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether d8:cb:8a:85:1f:69 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.20/24 brd 192.168.1.255 scope global noprefixroute dynamic enp4s0
       valid_lft 42810sec preferred_lft 42810sec
    inet6 fe80::49cf:3ffe:d19c:284/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: enp0s20u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:24:9b:23:3f:6c brd ff:ff:ff:ff:ff:ff
4: wlp5s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether f6:ae:22:7d:d0:e6 brd ff:ff:ff:ff:ff:ff
comme tu le vois je n'ai pas d'adresse ip coté Lan
de plus ma connexion internet via l'interface filaire de mon serveur ne fonctionne plus que par intermittence

de plus j'ai :

Code : Tout sélectionner

[root@Centos7-msi ~]# nmcli con show
NAME                 UUID                                  TYPE      DEVICE    
Connexion filaire 1  58aa846d-bfa8-3134-a403-c73eea40fc4d  ethernet  enp0s20u2 
connexion filaire    f567956d-9d5a-4a2a-9090-8d853f679d74  ethernet  enp4s0    
Freebox-4B26F0       0664be9a-f11a-4bbc-a553-560921e3dbd8  wifi      --        
[root@Centos7-msi ~]# nmcli con up 58aa846d-bfa8-3134-a403-c73eea40fc4d
Erreur : l'activation de la connexion a échoué : La configuration IP n'a pas pu être réservée (aucun adresse disponible, délai d'expiration, etc. )
je craque!! j'en ai révé!!!!

Beta-Pictoris
Messages : 976
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 23 septembre 2018, 12:39

Il y a certainement un paramètre qui perturbe ta configuration sur ton serveur.
Montre les paramètres de la connexion partagée:

Code : Tout sélectionner

nmcli connection show 58aa846d-bfa8-3134-a403-c73eea40fc4d
Et les paramètres du pare-feu:

Code : Tout sélectionner

firewall-cmd --list-all-zones

trazomtg
Messages : 127
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 23 septembre 2018, 13:12

voici voila!!

Code : Tout sélectionner

[root@Centos7-msi ~]# nmcli connection show 58aa846d-bfa8-3134-a403-c73eea40fc4d
connection.id:                          Connexion filaire 1
connection.uuid:                        58aa846d-bfa8-3134-a403-c73eea40fc4d
connection.stable-id:                   --
connection.type:                        802-3-ethernet
connection.interface-name:              --
connection.autoconnect:                 oui
connection.autoconnect-priority:        0
connection.autoconnect-retries:         -1 (default)
connection.auth-retries:                -1
connection.timestamp:                   1537691399
connection.read-only:                   non
connection.permissions:                 --
connection.zone:                        --
connection.master:                      --
connection.slave-type:                  --
connection.autoconnect-slaves:          -1 (default)
connection.secondaries:                 --
connection.gateway-ping-timeout:        0
connection.metered:                     inconnu
connection.lldp:                        default
802-3-ethernet.port:                    --
802-3-ethernet.speed:                   0
802-3-ethernet.duplex:                  --
802-3-ethernet.auto-negotiate:          non
802-3-ethernet.mac-address:             --
802-3-ethernet.cloned-mac-address:      --
802-3-ethernet.generate-mac-address-mask:--
802-3-ethernet.mac-address-blacklist:   --
802-3-ethernet.mtu:                     auto
802-3-ethernet.s390-subchannels:        --
802-3-ethernet.s390-nettype:            --
802-3-ethernet.s390-options:            --
802-3-ethernet.wake-on-lan:             default
802-3-ethernet.wake-on-lan-password:    --
ipv4.method:                            manual
ipv4.dns:                               --
ipv4.dns-search:                        --
ipv4.dns-options:                       ""
ipv4.dns-priority:                      0
ipv4.addresses:                         192.168.0.1/24
ipv4.gateway:                           192.168.1.254
ipv4.routes:                            --
ipv4.route-metric:                      -1
ipv4.route-table:                       0 (unspec)
ipv4.ignore-auto-routes:                non
ipv4.ignore-auto-dns:                   non
ipv4.dhcp-client-id:                    --
ipv4.dhcp-timeout:                      0 (default)
ipv4.dhcp-send-hostname:                oui
ipv4.dhcp-hostname:                     --
ipv4.dhcp-fqdn:                         --
ipv4.never-default:                     non
ipv4.may-fail:                          oui
ipv4.dad-timeout:                       -1 (default)
ipv6.method:                            auto
ipv6.dns:                               --
ipv6.dns-search:                        --
ipv6.dns-options:                       ""
ipv6.dns-priority:                      0
ipv6.addresses:                         --
ipv6.gateway:                           --
ipv6.routes:                            --
ipv6.route-metric:                      -1
ipv6.route-table:                       0 (unspec)
ipv6.ignore-auto-routes:                non
ipv6.ignore-auto-dns:                   non
ipv6.never-default:                     non
ipv6.may-fail:                          oui
ipv6.ip6-privacy:                       0 (désactivé)
ipv6.addr-gen-mode:                     stable-privacy
ipv6.dhcp-send-hostname:                oui
ipv6.dhcp-hostname:                     --
ipv6.token:                             --
proxy.method:                           none
proxy.browser-only:                     non
proxy.pac-url:                          --
proxy.pac-script:                       --
et

Code : Tout sélectionner

[root@Centos7-msi ~]# firewall-cmd --list-all-zones
block
  target: %%REJECT%%
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: 
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


dmz
  target: default
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: ssh
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


drop
  target: DROP
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: 
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


external
  target: default
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: ssh
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


home
  target: default
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: ssh mdns samba-client dhcpv6-client
  ports: 
  protocols: 
  masquerade: yes
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


internal
  target: default
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: ssh mdns samba-client dhcpv6-client
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


public
  target: default
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: ssh dhcpv6-client ftp
  ports: 
  protocols: 
  masquerade: yes
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


trusted (active)
  target: ACCEPT
  icmp-block-inversion: no
  interfaces: enp4s0
  sources: 
  services: 
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 


work
  target: default
  icmp-block-inversion: no
  interfaces: 
  sources: 
  services: ssh dhcpv6-client
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

Beta-Pictoris
Messages : 976
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 23 septembre 2018, 13:43

Ton pare-feu est mal configuré sur ton serveur. Fais ceci (en root):

Code : Tout sélectionner

firewall-cmd --zone=home --remove-masquerade
firewall-cmd --zone=public --remove-masquerade
firewall-cmd --zone=external --change-interface=enp4s0
firewall-cmd --zone=trusted --change-interface=enp0s20u2
firewall-cmd --runtime-to-permanent
firewall-cmd --reload
Idem pour ta connexion partagée:

Code : Tout sélectionner

nmcli connection edit 58aa846d-bfa8-3134-a403-c73eea40fc4d
remove ipv4.addresses
remove ipv4.gateway
set ipv4.method shared
set ipv4.never-default yes
verify
save
activate
CTRL-D
Montre les paramètres de ta connexion internet:

Code : Tout sélectionner

nmcli connection show f567956d-9d5a-4a2a-9090-8d853f679d74

trazomtg
Messages : 127
Inscription : 19 juillet 2016, 13:27

Re: configurer cle USB/Ethernet

Message par trazomtg » 23 septembre 2018, 16:04

qu'est ce qui est mal configuré dans le firewall?
j'aimerais bien comprendre un peu ce que je fais :roll:
qu'est ce que c'est que "masquerade" ? ça remplace le NAT?

j'ai rebooté et je n'ai pas de connexion sur mon interface Lan:

Code : Tout sélectionner

[root@Centos7-msi ~]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether d8:cb:8a:85:1f:69 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.20/24 brd 192.168.1.255 scope global noprefixroute dynamic enp4s0
       valid_lft 43076sec preferred_lft 43076sec
    inet6 fe80::49cf:3ffe:d19c:284/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: enp0s20u2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:24:9b:23:3f:6c brd ff:ff:ff:ff:ff:ff
4: wlp5s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether ae:f1:a9:9a:08:6f brd ff:ff:ff:ff:ff:ff 

Beta-Pictoris
Messages : 976
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: configurer cle USB/Ethernet

Message par Beta-Pictoris » 23 septembre 2018, 16:52

Oui, le masquerade, c'est pour avoir du NAT. Mais, il était inutilement activé dans certaines zones du pare-feu.
Le mode shared doit activer le masquerade automatiquement. Ce n'est pas la peine de l'activer.
Et tes interfaces réseaux n'étaient pas dans les bonnes zones.

Est-ce que ton interface partagée est en mode shared maintenant ? Que donne ?

Code : Tout sélectionner

nmcli connection show 58aa846d-bfa8-3134-a403-c73eea40fc4d

Répondre