Page 1 sur 1

Error nmcli add team-slave

Publié : 11 décembre 2018, 12:23
par david.verdier
Bonjour,
Sur une machine en CentOS7, j'essaie de rajouter un membre à une interface réseau en teaming, mais j'ai une erreur lors de l'ajout
# nmcli con add type team-slave con-name team1.port2 master team-team1 ifname ens1f1
Error: Failed to add 'team1.port2' connection: team-port.queue-id: propri▒t▒ inconnue

Effectivement, il ne me créé pas mon interface slave
[root@lsar0245 network-scripts]# nmcli con
NAME UUID TYPE DEVICE
ens1f1 abf5de33-ef0b-4368-9191-2b410a1410f3 ethernet ens1f1
team-team0 5b302815-533a-4bdd-ad53-0c245b046d76 team team0
team-team1 e51ce59e-5f9f-4bea-8448-8677ce21eedc team team1
team0-port1 1529c529-a850-45e2-bc78-a240dc919b38 ethernet eno49
team1.port1 9aa237db-62d2-4c25-9438-f19a2623589b ethernet eno50
eno1 e8fd2e4c-45d5-456d-a0c7-a4eae2f6a397 ethernet --
eno2 7b5ec97d-edb1-4e3b-890b-9f0074544df3 ethernet --
eno3 d3095243-cfb8-4931-9ea0-9d63ca88234e ethernet --
eno4 e29f4f07-e4b2-4e59-992c-c3e67d9f5482 ethernet --
eno49 82c5c466-c073-4f49-a24e-b93f5b6da743 ethernet --
eno50 00326e80-5dc3-4774-b9c7-6a791203afd3 ethernet --
ens1f1 44c20151-43a4-436f-840a-a2bc19c92ca7 ethernet --

J'ai réussi à ajouter un port via iputils
# ip link set dev ens1f1 master team1
# teamdctl team1 state
setup:
runner: lacp
ports:
eno50
link watches:
link summary: up
instance[link_watch_0]:
name: ethtool
link: up
down count: 0
runner:
aggregator ID: 9, Selected
selected: yes
state: current
ens1f1
link watches:
link summary: up
instance[link_watch_0]:
name: ethtool
link: up
down count: 0
runner:
aggregator ID: 9, Selected
selected: yes
state: current
runner:
active: yes
fast rate: no

# teamnl team1 ports
9: ens1f1: up 10000Mbit FD
7: eno50: up 10000Mbit FD


Mais cela ne créé pas de fichier dans /etc/sysconfig/network-scripts donc ne sera pas pris au reboot ou alors je dois créé un fichier à la main mais c'est source d'erreur.

Auriez vous une idée d’où viens ce problème pour créé un port dans ma team? Google n'a rien donné.

Re: Error nmcli add team-slave

Publié : 11 décembre 2018, 22:53
par Beta-Pictoris
Cela peut dépendre de comment tu as configuré ta team master.
Tu as vu ce lien ? : http://www.linuxbuzz.com/teaming-bridgi ... nd-rhel-7/

Re: Error nmcli add team-slave

Publié : 11 décembre 2018, 23:08
par Beta-Pictoris
Regarde aussi la doc redhat. Je te mets le lien vers la section de configuration avec nmcli : https://access.redhat.com/documentation ... mmand_line