Démarrer lightdm

Blueberryone
Messages : 12
Inscription : 22 mars 2016, 18:49

Démarrer lightdm

Message par Blueberryone » 22 mars 2016, 18:55

Bonjour à tous,

Nouveau venu sur CentOS, je me trouve confronté à un petit problème.
Je suis sous l'environnement Mate.
Au démarrage j'arrive sur le terminal pour me loguer.
Comment faire pour arriver sur lightdm directement?
Lightdm est bien évidemment installé.
Je pense que ce doit être une question de level (3 au lieu de 5)
Mais je ne sais pas comment faire pour mettre le level à 5
Je précise que j'ai fait une installation minimale de CentOS sur laquelle j'ai ajouté Mate Desktop
Quelqu'un peut-il m'aider à résoudre mon problème?
Merci d'avance
CentOS 7 avec Mate Desktop 64bit

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Démarrer lightdm

Message par Beta-Pictoris » 22 mars 2016, 19:40

Sous Centos 7, les services sont gérés par "Systemd".

Tu peux obtenir le "level" par défaut via la commande suivante:

Code : Tout sélectionner

systemctl get-default
Pour passer en mode graphique, fait ceci:

Code : Tout sélectionner

systemctl set-default graphical.target
systemctl isolate graphical.target

Blueberryone
Messages : 12
Inscription : 22 mars 2016, 18:49

Re: Démarrer lightdm

Message par Blueberryone » 22 mars 2016, 19:48

Bonjour Beta-Pictoris et merci de bien vouloir m'aider.

Voici ce que j'obtiens dans le terminal:

[blueberry@atlantis ~]$ su
Mot de passe :
[root@atlantis blueberry]# systemctl set-default graphical.target
Removed symlink /etc/systemd/system/default.target.
Created symlink from /etc/systemd/system/default.target to /usr/lib/systemd/system/graphical.target.
[root@atlantis blueberry]# systemctl isolate graphical.target
PolicyKit daemon disconnected from the bus.
We are no longer a registered authentication agent.
[root@atlantis blueberry]#

Il me semble que tout n'est pas passé!
Qu'en penses-tu?
CentOS 7 avec Mate Desktop 64bit

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Démarrer lightdm

Message par Beta-Pictoris » 22 mars 2016, 20:42

Tu es bien connecté en direct ? (Pas de ssh)

Vérifie, aussi, le status de lightdm

Code : Tout sélectionner

systemctl status lightdm

Blueberryone
Messages : 12
Inscription : 22 mars 2016, 18:49

Re: Démarrer lightdm

Message par Blueberryone » 22 mars 2016, 20:57

Non pas de ssh ( à ce que je sais)!

Voici ce que donne la commande suggérée:

[root@atlantis blueberry]# systemctl status lightdm
● lightdm.service - Light Display Manager
Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: enabled)
Active: active (running) since mar 2016-03-22 19:54:30 CET; 1min 54s ago
Docs: man:lightdm(1)
Main PID: 1061 (lightdm)
CGroup: /system.slice/lightdm.service
├─1061 /usr/sbin/lightdm
├─1285 /usr/bin/X -background none :0 -seat seat0 -auth /var/run/l...
└─2718 /usr/bin/gnome-keyring-daemon --daemonize --login

mar 22 19:54:29 atlantis systemd[1]: Starting Light Display Manager...
mar 22 19:54:30 atlantis systemd[1]: Started Light Display Manager.
mar 22 19:54:32 atlantis lightdm[1323]: pam_unix(lightdm-greeter:session): s...)
mar 22 19:54:55 atlantis gnome-keyring-daemon[2718]: The GPG agent was alread...
mar 22 19:54:55 atlantis gnome-keyring-daemon[2718]: The PKCS#11 component wa...
mar 22 19:54:55 atlantis gnome-keyring-daemon[2718]: The Secret Service was a...
mar 22 19:54:55 atlantis gnome-keyring-daemon[2718]: The SSH agent was alread...
Hint: Some lines were ellipsized, use -l to show in full.
CentOS 7 avec Mate Desktop 64bit

Beta-Pictoris
Messages : 1017
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Démarrer lightdm

Message par Beta-Pictoris » 22 mars 2016, 21:05

Apparemment, lightdm tourne. Vérifie les différentes consoles via les raccourcis ctrl-alt-f1, ctrl-alt-f2, ctrl-alt-f3,....

Répondre