Problème php + index

Eonelia
Messages : 6
Inscription : 29 mars 2016, 16:39

Problème php + index

Message par Eonelia » 29 mars 2016, 16:52

Bonjour,

Je viens vous demander votre aide car là, je patoge depuis 3h sur un problème que je n'ai jamais rencontré auparavant.

Je viens d'installer un CentOS 7 tout frais sur une VM pour en faire un serveur web.

J'installe donc php et httpd, tout est bon.

http://localhost m'affiche bien la page de Apache.

Maintenant, je télécharge phpmyadmin, je décompresse et déplace le dossier dans /var/www/html.

C'est à l’exécution que ça se complique. Je tape donc http://localhost/phpmyadmin et là, page blanche !

J'éxécute donc la commande

Code : Tout sélectionner

tail -f /var/log/httpd/error_log
, je retourne sur phpmyadmin et là; voici ce qui me sort :

Code : Tout sélectionner

PHP Warning : Unknown:  Failed to open stream: Permission denied in Unknown on Line 0
PHP Fatal Error : Unknown: Failed opening required '/var/www/html/phpmyadmin/index.php' (include_path='/usr/share/php:/usr/share/php') in Unknown on line 0
- chown -R apache /var/www/html : sans succès
- chown -R utilisateur /var/www/html : sans succès
- chmod -R 755 /var/www/html : sans succès
- chmod -R 777 /var/www/html : sans succès
- Modifier dans php.ini "include_path=/usr/share/pear/PEAR:/usr/share/php" : sans succès

Par contre, j'ai fait un fichier :

Code : Tout sélectionner

<?php
print_r(phpinfo());
?>
Et j'ai bien le tableau phpinfo ...

Pourtant, il y a quelques semaine, j'ai installé un serveur web sous CentOS 7 (même ISO) avec php et httpd, et je n'ai pas rencontré de problèmes.

Je comprend pas, sur le net tout le monde parle de problèmes de droits, j'ai pourtant tout fait, et toujours rien ...

Je vous remercie grandement par avance pour votre aide :D
Dernière modification par Eonelia le 30 mars 2016, 11:04, modifié 2 fois.

Avatar de l’utilisateur
remi
Messages : 211
Inscription : 20 octobre 2009, 07:10
Localisation : Champagne...
Contact :

Re: Problème php + index

Message par remi » 29 mars 2016, 17:51

Pourquoi ne pas simplement

Code : Tout sélectionner

yum install phpMyAdmin
;)
Contributeur EPEL et CentOS SCLo SIG
Des RPM pour CentOS sur https://rpms.remirepo.net

Eonelia
Messages : 6
Inscription : 29 mars 2016, 16:39

Re: Problème php + index

Message par Eonelia » 30 mars 2016, 10:09

C'est ce que j'avais essayé de faire, mais il ne le trouvait pas.

J'ai installé epel-release et c'est tout bon :).

Merci beaucoup :)

Edit : En fait pas résolu.

Pour PhpMyAdmin, ça fonctionne. Mais pas pour le reste. Je voudrai installer wordpress, j'ai décompréssé le dossier dans /var/www/html, et quand je veux y accéder, j'ai exactement le même message d'erreur que mon premier message.

Avatar de l’utilisateur
nouvo09
Messages : 1839
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème php + index

Message par nouvo09 » 30 mars 2016, 12:05

Tu as regardé du côté de SElinux ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Eonelia
Messages : 6
Inscription : 29 mars 2016, 16:39

Re: Problème php + index

Message par Eonelia » 30 mars 2016, 13:01

SELinux ? C'est à dire ?

Si tu parles des droits, voici ce que ls -l me renvoi :

Code : Tout sélectionner

drwxr-xr-x. 5 apache apache 4096 30 mars  11:02 salt
"salt" estmon dossier wordpress.

Code : Tout sélectionner

[utilisateur@Salt ~]$ ls -l /var/www/html/salt/
total 172
-rwxr-xr-x.  1 apache apache   418 25 sept.  2013 index.php
-rwxr-xr-x.  1 apache apache 19930  2 janv. 04:48 license.txt
-rwxr-xr-x.  1 apache apache  7360  9 janv. 13:56 readme.html
-rwxr-xr-x.  1 apache apache  5035  6 oct.  23:56 wp-activate.php
drwxr-xr-x.  9 apache apache  4096  2 févr. 18:11 wp-admin
-rwxr-xr-x.  1 apache apache   271  8 janv.  2012 wp-blog-header.php
-rwxr-xr-x.  1 apache apache  1369  3 oct.  16:47 wp-comments-post.php
-rwxr-xr-x.  1 apache apache  2849 30 mars  11:02 wp-config-sample.php
drwxr-xr-x.  4 apache apache  4096  2 févr. 18:11 wp-content
-rwxr-xr-x.  1 apache apache  3286 24 mai    2015 wp-cron.php
drwxr-xr-x. 16 apache apache  4096  2 févr. 18:12 wp-includes
-rwxr-xr-x.  1 apache apache  2380 25 oct.   2013 wp-links-opml.php
-rwxr-xr-x.  1 apache apache  3316  6 nov.  00:59 wp-load.php
-rwxr-xr-x.  1 apache apache 33770 21 déc.  04:30 wp-login.php
-rwxr-xr-x.  1 apache apache  7887  6 oct.  16:07 wp-mail.php
-rwxr-xr-x.  1 apache apache 13021 20 nov.  08:24 wp-settings.php
-rwxr-xr-x.  1 apache apache 28594 30 oct.  09:52 wp-signup.php
-rwxr-xr-x.  1 apache apache  4035 30 nov.   2014 wp-trackback.php
-rwxr-xr-x.  1 apache apache  3061  3 oct.  00:46 xmlrpc.php
Voici ce que me renvoi ls -Z :

Code : Tout sélectionner

[utilisateur@Salt ~]$ ls -Z /var/www/html/salt/
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 index.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 license.txt
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 readme.html
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-activate.php
drwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-admin
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-blog-header.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-comments-post.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-config-sample.php
drwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-content
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-cron.php
drwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-includes
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-links-opml.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-load.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-login.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-mail.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-settings.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-signup.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 wp-trackback.php
-rwxr-xr-x. apache apache unconfined_u:object_r:user_home_t:s0 xmlrpc.php

Avatar de l’utilisateur
nouvo09
Messages : 1839
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème php + index

Message par nouvo09 » 30 mars 2016, 16:18

non. SElinux, c'est SElinux

que renvoie la commande

getenforce

?

as-tu installé et activé setroubleshootd ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Eonelia
Messages : 6
Inscription : 29 mars 2016, 16:39

Re: Problème php + index

Message par Eonelia » 30 mars 2016, 16:27

Je connaissais pas du tout SELinux. Mais j'ai vu que je pouvais le désactiver, c'est ce que j'ai fait et ça fonctionne.

Mais je me pose une question : Quelle est la conséquence de le désactiver ? Est ce important comme service ?

Avatar de l’utilisateur
remi
Messages : 211
Inscription : 20 octobre 2009, 07:10
Localisation : Champagne...
Contact :

Re: Problème php + index

Message par remi » 30 mars 2016, 16:28

> Je voudrai installer wordpress,

Pareil, yum install wordpress ;)
Contributeur EPEL et CentOS SCLo SIG
Des RPM pour CentOS sur https://rpms.remirepo.net

Avatar de l’utilisateur
nouvo09
Messages : 1839
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème php + index

Message par nouvo09 » 30 mars 2016, 19:08

Eonelia a écrit :Je connaissais pas du tout SELinux. Mais j'ai vu que je pouvais le désactiver, c'est ce que j'ai fait et ça fonctionne.

Mais je me pose une question : Quelle est la conséquence de le désactiver ? Est ce important comme service ?
ça dépend de l'utilisation de ta machine. Si c'est une machine personnelle sur laquelle ne fonctionne aucun service devant être appelé de l 'extérieur comme un site internet ou NAS etc et que tu as un pare-feu bien paramétré, tu peux le désactiver.

En revanche puisque tu dois faire tourner un serveur alors il est indispensable de laisser SElinux activé.

Dans un premier temps tu peux le régler sur "permissive" ce qui te signalera les anomalies sans bloquer les choses. Ensuite il faudra le remettre sur "enforcing" mais pense à installer setroubleshoot.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Eonelia
Messages : 6
Inscription : 29 mars 2016, 16:39

Re: Problème php + index

Message par Eonelia » 31 mars 2016, 13:53

Pour le moment je l'ai désactivé le temps de vérifier si le serveur fonctionne.

Après je reprendrai la VM pour expérimenter SElinux et iptables, parce que un peu galère aussi :roll:

Edit : Quand je vais sur mon site depuis l'exterieur (salt.unice.fr), j'ai la page mal affichée, et tous les liens retournent sur localhost. Ca c'est surement le parametrage de wordpress.

Mais je peux pas me connecter à phpmyadmin à distance. J'ai

Code : Tout sélectionner

Forbidden

You don't have permission to access /phpmyadmin on this server.
Mon phpmyadmin.conf :

Code : Tout sélectionner

<VirtualHost */phpmyadmin:80>
   ServerName salt.unice.fr
   DocumentRoot /usr/share/phpMyAdmin

    <Directory "/usr/share/phpMyAdmin">
        DirectoryIndex index.php
        AllowOverride All
       Options Indexes FollowSymLinks
       Require all granted
    </Directory>
</VirtualHost>
Le soucis doit être au niveau de la première ligne, mais je vois pas comment je peux faire autrement ...

Répondre