Problème de démarrage avec le service SMB

vincke
Messages : 1
Inscription : 09 août 2016, 11:17

Problème de démarrage avec le service SMB

Message par vincke » 09 août 2016, 11:32

Bonjour à tous,

J'ai installé un CentOS 7 comme VM sur un virtualbox avec les tools.

Je souhaiterai installé un partage samba afin que ma Centos puisse communiquer avec des répertoires de partages Windows.

Durant la configuration de Samba, je peux arrêter le service smb mais celui-ci affiche un message d'erreur lors de son démarrage:

[root@localhost vincent]# service smb restart
Redirecting to /bin/systemctl restart smb.service
Job for smb.service failed because the control process exited with error code. See "systemctl status smb.service" and "journalctl -xe" for details.


Voici le status du service:
[root@localhost vincent]# service smb status
Redirecting to /bin/systemctl status smb.service
smb.service - Samba SMB Daemon
Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since mar. 2016-08-09 11:07:26 CEST; 2min 52s ago
Process: 6843 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=1/FAILURE)
Main PID: 6843 (code=exited, status=1/FAILURE)
août 09 11:07:26 localhost.localdomain systemd[1]: Starting Samba SMB Daemon...
août 09 11:07:26 localhost.localdomain systemd[1]: smb.service: main process exited, code=exited, status=1/FAILURE
août 09 11:07:26 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon.
août 09 11:07:26 localhost.localdomain systemd[1]: Unit smb.service entered failed state.
août 09 11:07:26 localhost.localdomain systemd[1]: smb.service failed.


En suivant cette conversation, https://www.centos.org/forums/viewtopic.php?t=53399, j'ai appliqué ces commandes et voilà ce que cela me donne:

[root@localhost vincent]# rpm -qf /lib64/libavahi-common.so.3
avahi-libs-0.6.31-15.el7.x86_64
[root@localhost vincent]# rpm -V avahi-libs
[root@localhost vincent]# yum reinstall avahi-libs
Modules complémentaires chargés : fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: miroir.univ-paris13.fr
* extras: miroir.univ-paris13.fr
* updates: ftp.pasteur.fr
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet avahi-libs.x86_64 0:0.6.31-15.el7 sera réinstallé
--> Résolution des dépendances terminée

Dépendances résolues

============================================================================================================================================
Package Architecture Version Dépôt Taille
============================================================================================================================================
Réinstallation :
avahi-libs x86_64 0.6.31-15.el7 base 61 k

Résumé de la transaction
============================================================================================================================================
Réinstallation 1 Paquet

Taille totale des téléchargements : 61 k
Taille d'installation : 121 k
Is this ok [y/d/N]: y
Downloading packages:
avahi-libs-0.6.31-15.el7.x86_64.rpm | 61 kB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installation : avahi-libs-0.6.31-15.el7.x86_64 1/1
Vérification : avahi-libs-0.6.31-15.el7.x86_64 1/1

Installé :
avahi-libs.x86_64 0:0.6.31-15.el7

Terminé !
[root@localhost vincent]# service smb status
Redirecting to /bin/systemctl status smb.service
● smb.service - Samba SMB Daemon
Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since mar. 2016-08-09 11:07:26 CEST; 5min ago
Process: 6843 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=1/FAILURE)
Main PID: 6843 (code=exited, status=1/FAILURE)

août 09 11:07:26 localhost.localdomain systemd[1]: Starting Samba SMB Daemon...
août 09 11:07:26 localhost.localdomain systemd[1]: smb.service: main process exited, code=exited, status=1/FAILURE
août 09 11:07:26 localhost.localdomain systemd[1]: Failed to start Samba SMB Daemon.
août 09 11:07:26 localhost.localdomain systemd[1]: Unit smb.service entered failed state.
août 09 11:07:26 localhost.localdomain systemd[1]: smb.service failed.


Comme vous pouvez le constater, cela n'a pas résolu le soucis, pourriez-vous m'aider à débloquer la situation s'il vous plaît ?

Merci bien.

Avatar de l’utilisateur
remi
Messages : 211
Inscription : 20 octobre 2009, 07:10
Localisation : Champagne...
Contact :

Re: Problème de démarrage avec le service SMB

Message par remi » 09 août 2016, 15:35

De mémoire, il y a un fichier de log /var/log/samba/ qui contient peut-être plus de détail.

Je pense qu'il peut-être utile de lancer nmb avant smb (j'ai un petit doute)
Contributeur EPEL et CentOS SCLo SIG
Des RPM pour CentOS sur https://rpms.remirepo.net

Répondre