Ouverture des ports 80 et 443

ephjiache
Messages : 5
Inscription : 25 avril 2017, 14:02

Ouverture des ports 80 et 443

Messagepar ephjiache » 25 avril 2017, 14:48

Bonjour à tous,

J'ai un problème que je n'arrive pas résoudre depuis plusieurs jours. Je n'arrive pas ouvrir le port 80 et/ou 443 de mon serveur web.

Pour ouvrir le port 8443 pour Plesk et 8447 pour son autoinstaller j'ai utilisé la commande:

Code : Tout sélectionner

root@plesk ~ # iptables -A INPUT -p tcp -m tcp --dport 8443 -j ACCEPT


Là ça fonctionne parfaitement.

Pour ouvrir le port 80 :

Code : Tout sélectionner

root@plesk ~ # iptables -A INPUT -p tcp -m tcp --dport 80-j ACCEPT


Mais là le port reste fermé.

Savez vous ce que je ne fais pas comme il faut?

Beta-Pictoris
Messages : 823
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Ouverture des ports 80 et 443

Messagepar Beta-Pictoris » 25 avril 2017, 17:27

Normal, tu dois utiliser firewalld: https://www.certdepot.net/rhel7-get-started-firewalld/

ephjiache
Messages : 5
Inscription : 25 avril 2017, 14:02

Re: Ouverture des ports 80 et 443

Messagepar ephjiache » 26 avril 2017, 11:46

Pourtant je n'ai jamais activé firewalld sur mon autre VPS qui est chez Digital Ocean et le port 80 est bien ouvert.

Image

Beta-Pictoris
Messages : 823
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Ouverture des ports 80 et 443

Messagepar Beta-Pictoris » 26 avril 2017, 18:08

Tu utilises, peut-être, une version modifiée de la Centos.

Peux tu nous donner la version ? :

Code : Tout sélectionner

cat /etc/centos-release

Et l'état de firewalld ? :

Code : Tout sélectionner

systemctl status firewalld

ephjiache
Messages : 5
Inscription : 25 avril 2017, 14:02

Re: Ouverture des ports 80 et 443

Messagepar ephjiache » 26 avril 2017, 18:59

Merci pour ta réponse. J'ai 7.3.611 sur les 2 VPS

Celui chez Digital Océan où j'ai pas eu de problème à l'installation:

Code : Tout sélectionner

[root@somac ~]# cat /etc/centos-release
CentOS Linux release 7.3.1611 (Core)

Celui qui pose problème sur certain port dont 53,80 et 443:

Code : Tout sélectionner

root@plesk ~ # cat /etc/centos-release
CentOS Linux release 7.3.1611 (Core)


Pour le Firewall si je me trompe pas il est inactif chez les 2. Chez Digital Océan:

Code : Tout sélectionner

[root@somac ~]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:firewalld(1)

Chez celui qui me pose problème:

Code : Tout sélectionner

root@plesk ~ # systemctl status firewalld
● firewalld.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)


Je débute avec CentOS mais j'ai installé et configuré Plesk plusieurs dois c'est la première fois que je bloque. Chez AWS, DigitalOcean et OVH pas de soucis, là c'est un serveur web qu'on héberge nous même en nos locaux je vois vraiment pas ce qui cloche...

Beta-Pictoris
Messages : 823
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Ouverture des ports 80 et 443

Messagepar Beta-Pictoris » 26 avril 2017, 20:30

As-tu scanné les ports de ton serveur d'une autre machine, avec nmap par exemple, pour contrôler la liste des ports ouverts ?

ephjiache
Messages : 5
Inscription : 25 avril 2017, 14:02

Re: Ouverture des ports 80 et 443

Messagepar ephjiache » 26 avril 2017, 20:39

Oui je viens encore de faire l'essai avant de te répondre. Le 8443 et 8447 était déjà ouvert. J'ai ouvert le 21 pour ce test et ça passe. Par contre 80 ou 443 toujours rien.

Vraiment, je bloque et je tourne en rond. Je crois que là meilleur solution est de laisser ça de coté un jour ou deux pour repartir avec un regarde "neuf".

Beta-Pictoris
Messages : 823
Inscription : 07 janvier 2014, 21:48
Localisation : Angers, France

Re: Ouverture des ports 80 et 443

Messagepar Beta-Pictoris » 27 avril 2017, 18:15

Il y a, peut-être, un problème de configuration dans le routeur/switch/firewall, qui bloque ou ne redirige pas correctement certains ports, où est connecté ton serveur ?

ephjiache
Messages : 5
Inscription : 25 avril 2017, 14:02

Re: Ouverture des ports 80 et 443

Messagepar ephjiache » 28 avril 2017, 12:47

Je viens de trouver. En fait Nginx était configuré en tant que reverse proxy. Ma config iptables était bonne.

J'ai bien fait de mettre ça de côté 2 jours.

Merci pour ton aide.


Revenir vers « [C7] Sécurité »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 1 invité