problème tls avec vsftpd

ph1823
Messages : 6
Inscription : 25 février 2019, 18:56

problème tls avec vsftpd

Message par ph1823 » 15 août 2020, 17:29

Bonjour, il y a quelque temps j'ai enfin décider de passer mon VPS Centos 7 sous Centos 8, j'ai donc tout réinstaller et reconfigurer propement.

Un seul logiciel à causer soucis: vSFTPD, le soucis et le suivant: lorsque ssl est désactiver, on peut se connecter sans soucis au serveur FTP. Lorsqu'il est activé, j'obtient ceci dans les logs: SSL_accept failed: error:00000000:lib(0):func(0):reason(0) et impossible de se connecter.

J'ai donc fais quelque recherche et tenter se qu'on me proposé, mais rien n'a marché.

Voici ma configuration de vSFTPD:

Code : Tout sélectionner

# No ANONYMOUS users allowed
anonymous_enable=NO
# Allow 'local' users with WRITE permissions (0755)
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
# if you want to LOG vsftpd activity then uncomment this  log_ftp_protocol
log_ftp_protocol=YES
connect_from_port_20=YES
# uncomment xferlog_file and xferlog_std_format if you  DIDN'T use the line above
# with log_ftp_protocol - it must be excluding each other
# The name of log file when xferlog_enable=YES and  xferlog_std_format=YES
# WARNING - changing this filename affects /etc/logrotate.d/vsftpd.log
xferlog_file=/var/log/xferlog
#
# xferlog_std_format Switches between logging into  vsftpd_log_file and xferlog_file files.
# NO writes to vsftpd_log_file, YES to xferlog_file
# xferlog_std_format=YES

ftp_username=datahosting
# define a unique user on your system which the
# ftp server can use as a totally isolated and unprivileged user.
nopriv_user=datahosting
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. By default, listening
# on the IPv6 "any" address (::) will accept connections from both IPv6
# and IPv4 clients. It is not necessary to listen on *both* IPv4 and IPv6
# sockets. If you want that (perhaps because you want to listen on specific
# addresses) then you must run two copies of vsftpd with two configuration
# files.
# Make sure, that one of the listen options is commented !!
listen_ipv6=NO
# here we use the authentication module for vsftpd to check users name  and passw
pam_service_name=vsftpd


userlist_enable=YES
chown_username=datahosting


# here the vsftpd will allow the 'vsftpd' user to login into the 
# '/home/vsftpd/$USER'  directory
chroot_local_user=YES
allow_writeable_chroot=YES
guest_enable=YES
guest_username=datahosting
user_sub_token=$USER
virtual_use_local_privs=YES
local_root=/home/$USER
user_config_dir=/home/datahosting/vsftpd_user_conf

#run_as_launching_user=yes

pasv_enable=YES
port_enable=YES
pasv_max_port=9997
pasv_min_port=9000

ascii_download_enable=YES
ascii_upload_enable=YES

dual_log_enable=YES
debug_ssl=YES
ssl_enable=YES
force_local_logins_ssl=NO

ssl_tlsv1_1=YES
ssl_tlsv1_2=YES

ssl_sslv2=YES
ssl_sslv3=YES

rsa_private_key_file=/home/datahosting/new-manager/ssl/privkey.pem
rsa_cert_file=/home/datahosting/new-manager/ssl/cert.pem
ca_certs_file=/home/datahosting/new-manager/ssl/origin_ca_rsa_root.pem
J'utilise des certificat donnée par cloudflare si jamais, ca viens peut être de la :?: Mais j'ai tester en générant les miens avec openssl ca à l'air de donner la même chose. (impossible de se connecter)
Je n'arrive pas à savoir d'ou viens le soucis, j'espère que quelqu'un pourra m'aider ! :)

Répondre