[Résolu]Carte NVidia GT1030 et écran 1440p

Jean-M
Messages : 111
Inscription : 06 juin 2014, 23:21
Localisation : Pays basque

[Résolu]Carte NVidia GT1030 et écran 1440p

Message par Jean-M » 28 mars 2020, 11:20

Bonjour,
Voila 3 jours que je suis passé de la 7.7 la version CentOS-8.1... (Installation nouvelle en conservant le /home et partition de données)
Mon problème :
Affichage limité à 1080p car je n'ai pas trouvé de driver compatible... J'ai essayé vainement une procédure avec un "NVIDIA-Linux-x86_64-440.64.run" qui modifie quelque chose dans grub mais au rechargement "ON" est en 640*480 inexploitable et je ne m'en suis sorti qu'en réinstallant tout !
Quelqu'un a-t-il la méthode et peux m'indiquer où la trouver ?
Merci d'avance

Code : Tout sélectionner

# lshw -C display
  *-display                 
       description: VGA compatible controller
       product: GP108 [GeForce GT 1030]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:27 memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff
Dernière modification par Jean-M le 03 juillet 2020, 09:40, modifié 3 fois.
Jean-M - Retraité ex-Ingénieur d'étude sur Grands Systèmes et Consultant Qualité
Équipement : CentOS Linux 8.1 (sur fixe I5-4690+GT1030 16Go)

Jean-M
Messages : 111
Inscription : 06 juin 2014, 23:21
Localisation : Pays basque

Re: Carte NVidia GT1030 et écran 1440p

Message par Jean-M » 07 avril 2020, 21:25

En combinant les dépôts CentOS et les RPM Fusion (updates) Free et non-free, j’ai installé tout ça :

Code : Tout sélectionner

mod-nvidia-4.18.0-147.el8.x86_64-440.64-1.el8.x86_64
kmod-nvidia-440.64-1.el8.x86_64
nvidia-modprobe-440.64-1.el8.x86_64
knvidia-settings-440.64-1.el8.x86_64
nvidia-xconfig-440.64-1.el8.x86_64
xorg-x11-drv-nvidia-440.64-2.el8.x86_64
xorg-x11-drv-nvidia-libs-440.64-2.el8.x86_64
xorg-x11-drv-nvidia-cuda-libs-440.64-2.el8.x86_64
Ainsi, j’ai dans le menu « Autre » « Paramètre du serveur X NVidia » qui m’a permis de passer en 2560*1440... :D
... mais il faut renouveler la manip à chaque rechargement ou changement d'utilisateur :?
Jean-M - Retraité ex-Ingénieur d'étude sur Grands Systèmes et Consultant Qualité
Équipement : CentOS Linux 8.1 (sur fixe I5-4690+GT1030 16Go)

Jean-M
Messages : 111
Inscription : 06 juin 2014, 23:21
Localisation : Pays basque

Re: Carte NVidia GT1030 et écran 1440p

Message par Jean-M » 05 mai 2020, 16:56

Bonjour,
Toujours avec mon problème d'écran 1440p ! :?
Existe-t-il un moyen de mémoriser la configuration de telle manière que quand je recharge le système ou quand il y a changement d'utilisateur, il ne soit plus nécessaire de reparamétrer la définition de l'écran en 2560x1440 ?
L'utilitaire système Gnome "Paramètres" puis Écran ne propose pas cette définition le max est FHD.

Pour info l'écran est un ACER K272HUL (un 27" WQHD) branché en DVI-D de la GT1030.
Jean-M - Retraité ex-Ingénieur d'étude sur Grands Systèmes et Consultant Qualité
Équipement : CentOS Linux 8.1 (sur fixe I5-4690+GT1030 16Go)

Avatar de l’utilisateur
nouvo09
Messages : 2169
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Carte NVidia GT1030 et écran 1440p

Message par nouvo09 » 05 mai 2020, 17:43

Si tu es sous Xorg alors tu peux définir ça dans le fichier Xorg.conf ou dans un fichier situé dans Xorg.conf.d
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Jean-M
Messages : 111
Inscription : 06 juin 2014, 23:21
Localisation : Pays basque

Re: Carte NVidia GT1030 et écran 1440p

Message par Jean-M » 06 mai 2020, 00:02

Bonsoir,
Dans le répertoire /etc/X11/Xorg.conf.d , il n'y a qu'un fichier nommé 00-keyboard.conf (rien à voir, et je n'est pas de bille pour ajouter un nouveau fichier) ; dans le fichier /etc/X11/xorg.conf, j'ai fait une modif en laissant la ligne non-modifiée en commentaire... mais c'est sans effet.

Code : Tout sélectionner

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.64

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer K272HUL"
    HorizSync       31.0 - 89.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 1030"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-D-0: 2560x1440 +0+0 {AllowGSYNC=Off}"
#    Option         "metamodes" "nvidia-auto-select +0+0 {viewportin=2560x1440}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Jean-M - Retraité ex-Ingénieur d'étude sur Grands Systèmes et Consultant Qualité
Équipement : CentOS Linux 8.1 (sur fixe I5-4690+GT1030 16Go)

Avatar de l’utilisateur
nouvo09
Messages : 2169
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Carte NVidia GT1030 et écran 1440p

Message par nouvo09 » 06 mai 2020, 10:55

C'est toujours quelque peu ésotérique la gestion des cartes Nvidia..

Ton écran est bien connecté en DVI ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Jean-M
Messages : 111
Inscription : 06 juin 2014, 23:21
Localisation : Pays basque

Re: Carte NVidia GT1030 et écran 1440p

Message par Jean-M » 06 mai 2020, 13:19

Bonjour,
Oui, c'est bien en DVI (pas de DP sur ma carte GT1030 ni sur l'écran) et le HDMI de l'écran est utilisé pour une Adroïd-TV-box.
En fait, il faut peut-être un fichier nn-screen.conf dans /etc/X11/Xorg.conf.d mais je n'ai aucune information ou alors un paramètre dans grub pour que le paramétrage passe du chargeur au système ???
Bon, je ne suis pas bloqué, c'est juste une histoire de confort mais c'est un peu dommage. :?

PS:
Peut-être une piste, sur forum Ubuntu j'ai trouvé un truc (avec 2 commandes) :
la première (console root) passe :

Code : Tout sélectionner

# xrandr --newmode "2560x1440_60" 241.50 2560 2608 2640 2720 1440 1442 1447 1481 +hsync +vsync
la seconde... moins bon :

Code : Tout sélectionner

# xrandr --addmode DVI-D-0 2560x1440_60
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  25
  Current serial number in output stream:  26
#
Le résultat ... c'est de l'Hébreux à la sauce Pidgin pour moi !
Jean-M - Retraité ex-Ingénieur d'étude sur Grands Systèmes et Consultant Qualité
Équipement : CentOS Linux 8.1 (sur fixe I5-4690+GT1030 16Go)

Avatar de l’utilisateur
nouvo09
Messages : 2169
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Carte NVidia GT1030 et écran 1440p

Message par nouvo09 » 06 mai 2020, 18:16

Je file apprendre l''hébreu alors
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Jean-M
Messages : 111
Inscription : 06 juin 2014, 23:21
Localisation : Pays basque

Re: [Résolu]Carte NVidia GT1030 et écran 1440p

Message par Jean-M » 03 juillet 2020, 09:43

Bonjour,
Depuis le passage en CentOS-8.2, la configuration écran 1440p est mémorisée (plus besoin de forcer la définition de l'écran à chaque ouverture de session).
Bonne journée.
Jean-M - Retraité ex-Ingénieur d'étude sur Grands Systèmes et Consultant Qualité
Équipement : CentOS Linux 8.1 (sur fixe I5-4690+GT1030 16Go)

Répondre