PHP Mysl

Support général incluant les problèmes liés à l'installation.
soume86
Messages : 64
Inscription : 06 mars 2012, 10:38

PHP Mysl

Message par soume86 » 14 janvier 2013, 18:26

Bonjour à tous,

J'essaie d'installer les paquets suivants sans succès:

Code : Tout sélectionner

[root@localhost ~/rpm]$ rpm -ivh mysqlclient14-4.1.22-1.el4.remi.i386.rpm mysql-4.1.7-4.RHEL4.1.i386.rpm perl-DBD-MySQL-2.9004-3.1.i386.rpm php-mysql-5.2.17-1.el4.art.i3
Message d'erreur:

Code : Tout sélectionner

Préparation...              ########################################### [100%]
        le fichier /usr/lib/mysql/libmysqlclient.so.14.0.0 entre en conflit avec les tentatives d'installation de mysql-4.1.7-4.RHEL4.1 et mysqlclient14-4.1.22-1.el4.remi
        le fichier /usr/lib/mysql/libmysqlclient_r.so.14.0.0 entre en conflit avec les tentatives d'installation de mysql-4.1.7-4.RHEL4.1 et mysqlclient14-4.1.22-1.el4.remi
J'ai essayé aussi l'option "rpm -Uvh" sans succès.
Si quelqu'un peut m'indiquer la marche à suivre pour installer ces deux paquets, ce serait sympa!

Je vous remercie d'avance!

Avatar de l’utilisateur
neowdj1
Messages : 262
Inscription : 25 octobre 2009, 23:30
Localisation : Lille

Re: PHP Mysl

Message par neowdj1 » 14 janvier 2013, 23:54

et comme ca ?


tu install le dépot remi pour centos 4

Code : Tout sélectionner

wget http://dl.fedoraproject.org/pub/epel/4/i386/epel-release-4-10.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-4.rpm
rpm -Uvh remi-release-4*.rpm epel-release-4*.rpm
ensuite tu passe par yum
yum --enablerepo=remi update mysql-server
http://blog.famillecollet.com/post/2012 ... sql-5.5.29

sinon si tu na pas de bases de données mysql

Code : Tout sélectionner

yum remove mysql mysqlclient mysql-server php-mysql

soume86
Messages : 64
Inscription : 06 mars 2012, 10:38

Re: PHP Mysl

Message par soume86 » 15 janvier 2013, 13:16

Bonjour,

Je suis sous redhat 4 et la commande yum n'est pas installée.

Est ce que y'aurait pas une alternative? en utilisant la commande rpm par exemple?

Est ce qu'il faut installer d'autres version de ces packets?

Merci d'avance.

Avatar de l’utilisateur
nouvo09
Messages : 2299
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: PHP Mysl

Message par nouvo09 » 15 janvier 2013, 21:34

Si tu utilises rpm - et je ne vois pas à priori d'alternative - tu devras gérer les dépendances toi même alors.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

soume86
Messages : 64
Inscription : 06 mars 2012, 10:38

Re: PHP Mysl

Message par soume86 » 16 janvier 2013, 11:03

Oui je sais que je dois gérer les dépendances moi même mais ici j'ai pas de problème de dépendance, non?

Mon problème c'est que je sais pas quoi faire avec ce message d'erreur?

Est ce que vous pouvez me dire ce qu'il faut faire? Faut installer d'autres paquets.....?

Merci d'avance.

Avatar de l’utilisateur
nouvo09
Messages : 2299
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: PHP Mysl

Message par nouvo09 » 16 janvier 2013, 12:32

Commence par installer le paquet avec les composants les plus récents:

rpm -ivh mysqlclient14-4.1.22-1.el4.remi.i386.rpm
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

soume86
Messages : 64
Inscription : 06 mars 2012, 10:38

Re: PHP Mysl

Message par soume86 » 16 janvier 2013, 13:31

J'ai commencé par installer le paquet mysqlclient le plus récent comme conseiller mais lorsque j'essaie d'installer le paquets mysql j'ai la même erreur:

Code : Tout sélectionner

[root@localhost ~/bonrpm]$ rpm -ivh mysqlclient14-4.1.22-1.el4.remi.i386.rpm
attention: mysqlclient14-4.1.22-1.el4.remi.i386.rpm: signature V3 DSA: NOKEY, key ID 00f97f56
Préparation...              ########################################### [100%]
   1:mysqlclient14          ########################################### [100%]

Code : Tout sélectionner

[root@localhost ~/bonrpm]$ rpm -ivh mysql-4.1.7-4.RHEL4.1.i386.rpm perl-DBD-MySQL-2.9004-3.1.i386.rpm
Préparation...              ########################################### [100%]
        le fichier /usr/lib/mysql/libmysqlclient.so.14.0.0 de l'installation de mysql-4.1.7-4.RHEL4.1 entre en conflit avec le fichier du paquetage mysqlclient14-4.1.22-1.el4.remi
        le fichier /usr/lib/mysql/libmysqlclient_r.so.14.0.0 de l'installation de mysql-4.1.7-4.RHEL4.1 entre en conflit avec le fichier du paquetage mysqlclient14-4.1.22-1.el4.remi
D'autres suggestions?

Avatar de l’utilisateur
nouvo09
Messages : 2299
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: PHP Mysl

Message par nouvo09 » 16 janvier 2013, 14:44

Où as-tu trouvé ces paquets ? Je n'arrive même pas à les trouver.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

soume86
Messages : 64
Inscription : 06 mars 2012, 10:38

Re: PHP Mysl

Message par soume86 » 16 janvier 2013, 16:16

Le paquet mysqlclient14-4.1.22-2.el4.art.i386.rpm --> https://www6.atomicorp.com/channels/ato ... i386/RPMS/ et l'autre sur le CD d'install de redhat4!!!

Avatar de l’utilisateur
nouvo09
Messages : 2299
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: PHP Mysl

Message par nouvo09 » 16 janvier 2013, 18:26

Alors si tu mélanges les dépots il est clair que tu auras des incompatibilités.

Tu as des raisons spéciales pour ne pas installer les dernières versions de ces paquets depuis le dépôt remi ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

Verrouillé