Problème de reconnaissance écran et/ou carte graphique

et76
Messages : 70
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Problème de reconnaissance écran et/ou carte graphique

Message par et76 » 04 janvier 2019, 16:18

Bonjour et bonne année
Je suis sous centos 7 avec un PC équipé d'une carte graphique AMD/ATI radeon HD 6850 et d'un écran Iiyama Prolite E1906S et voila mon problème au démarrage de centos j'ai l'affichage

Code : Tout sélectionner

drm : radeon_init [radeon]] *ERROR* no UMS support in radeon module
Avant la réinstallation de ma centos 7 pas de problème. Naturellemnt j'ai des problèmes d'affichage, pas énormes mais usants.
Dans paramètres l'écran est inconnu mais dans LSPCI la réponse est

Code : Tout sélectionner

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Barts PRO [Radeon HD 6850]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM]
et dans paramètres détail j'ai pour la carte graphique

Code : Tout sélectionner

lvmpipe (LLVM 6.0, 256 bits)
la commande xrandr répond

Code : Tout sélectionner

[j@PI3100 ~]$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 400, current 1280 x 1024, maximum 1280 x 1024
default connected primary 1280x1024+0+0 0mm x 0mm
   1280x1024      0.00* 
   640x480        0.00  
   720x400        0.00  
[j@PI3100 ~]$ 
Dans ma fedora 29 pas de problème carte graphique et écran bien reconnu.
Comment résoudre ces problèmes
Merci d'avance
A+

et76
Messages : 70
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème de reconnaissance écran et/ou carte graphique

Message par et76 » 05 janvier 2019, 11:17

Je reviens sur mon problème de reconnaissance de la carte graphique et de mon écran, pourquoi avec un DVD live gnome centos 7, celui qui a servit à l'installation la carte et l'écran sont correctement reconnus ?

Avatar de l’utilisateur
nouvo09
Messages : 1894
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème de reconnaissance écran et/ou carte graphique

Message par nouvo09 » 05 janvier 2019, 11:30

Tu as regardé la configuration de Xorg ?
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

et76
Messages : 70
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème de reconnaissance écran et/ou carte graphique

Message par et76 » 05 janvier 2019, 12:43

Je veux bien mais dans mon dossier /etc/x11 je ne trouve pas de fichier *.conf comme indiqué dans la doc de fedora.
Alors une direction a suivre ?
A+

Avatar de l’utilisateur
nouvo09
Messages : 1894
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème de reconnaissance écran et/ou carte graphique

Message par nouvo09 » 06 janvier 2019, 11:58

Je dirais bien d'essayer d'installer le pilote proprio ce qui ne devrait pas poser de problème avec le noyau 3.xx

Mais fais une sauvegarde du système auparavant.
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

et76
Messages : 70
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème de reconnaissance écran et/ou carte graphique

Message par et76 » 06 janvier 2019, 19:07

Pourquoi pas mais pourquoi avec la version live le problème n'existe pas, sauf erreur c'est le driver nouveau qui est utilisé et le dernier serait moins bon que celui du live ?
A+

Avatar de l’utilisateur
nouvo09
Messages : 1894
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème de reconnaissance écran et/ou carte graphique

Message par nouvo09 » 06 janvier 2019, 23:08

Le pilote nouveau est utilisé pour les cartes Nvidia, pas amd
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

et76
Messages : 70
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème de reconnaissance écran et/ou carte graphique

Message par et76 » 07 janvier 2019, 10:57

Donc il faut que je trouve la commande pour que le driver x11 ati soit utilisé et si c'est nouveau que je le rendes inactif ?

Avatar de l’utilisateur
nouvo09
Messages : 1894
Inscription : 20 octobre 2009, 08:14
Localisation : Paris, France

Re: Problème de reconnaissance écran et/ou carte graphique

Message par nouvo09 » 07 janvier 2019, 13:09

avant tout vérifie lequel est utilisé. Tu trouveras cette info dans le fichier /var/log/Xorg.0.log
C'est pas parce que c'est difficile qu'on ose pas,
c'est parce qu'on ose pas que c'est difficile !

et76
Messages : 70
Inscription : 19 février 2014, 19:08
Localisation : enirons de Rouen

Re: Problème de reconnaissance écran et/ou carte graphique

Message par et76 » 08 janvier 2019, 20:01

Me revoila après étude du fichier /varl/log/x11/xorf-0.log il mes semble avoir compris sur l'écran n'est pas trouvé

Code : Tout sélectionner

[    96.799] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    96.799] (==) No Layout section.  Using the first Screen section.
[    96.799] (==) No screen section available. Using defaults.
[    96.799] (**) |-->Screen "Default Screen Section" (0)
[    96.799] (**) |   |-->Monitor "<default monitor>"
[    96.800] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
plus loin que le module radeon est compilé et chargé

Code : Tout sélectionner

96.945] (II) LoadModule: "radeon"
[    96.946] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
mais plus loin que le module radeon est déchargé

Code : Tout sélectionner

96.963] (EE) Screen 0 deleted because of no matching config section.
[    96.963] (II) UnloadModule: "radeon"
[    96.963] (EE) Screen 0 deleted because of no matching config section.
[    96.963] (II) UnloadModule: "modesetting"
[    96.963] (EE) Screen 0 deleted because of no matching config section.
[    96.963] (II) UnloadModule: "fbdev"
[    96.963] (II) UnloadSubModule: "fbdevhw"
Encore plus loin il y a une recherche d'écran sous VESA, un écran est défini avec une faible mémoire

Code : Tout sélectionner

 97.032] (II) VESA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32

Code : Tout sélectionner

 97.155] (II) VESA(0): Serial No: 11013G1204023
[    97.155] (II) VESA(0): Ranges: V min: 55 V max: 76 Hz, H min: 30 H max: 83 kHz, PixClock max 145 MHz
[    97.155] (II) VESA(0): Monitor name: PL1906
à un moment le module radeon est rechargé.
Ce que j'ai compris c'est qu'il manque une section de définition de mon écran mais où ?
En lisant la doc sur xorg de la documentation sur le forume fedora.fr on y parle de section Device concernat la carte video, d'une section Monitor et d'une autre Screen concernant l'écran amis comme ces sections ne sont pas dans le fichier etc/x11/ où les trouver et comment faire qu'elles soient associées.
Je le redis avec le liveGnome de la version 1810 7.6 de centos écran et carte sont reconnus malgré le fichier var/log semblabe.
A+

Répondre